10

On a laptop where was previously installed Windows 8.1 I was perfectly able to use the hibernation feature. I have upgraded to Windows 10 and now the hibernation feature is disabled. If I run a powercfg -a command it tells me that the hibernation is not available for a very strange reason to me. It says, more or less since I am translating the text from another language, that the hibernation file type does not support the hibernation.

Does anybody have any idea of what this means?

I verified and on the root of my C: drive I have a hiberfil.sys if I enable the hibernation via the powercfg -h on and the file is removed if I issue the off command. Strangly the file size is only of 300MB when my installed RAM is 1.5GB. I still have 50GB of free space and I am using an SSD drive.

Many thanks!

10

I found the solution: in fact the file was too small!

I don't know why powercfg -h sets the file so small automatically, but running the following fixed the problem:

powercfg -h -size 75%
  • Or 100% :-) Machines are getting too big for microsoft's lame defaults. (this laptop has 32GB. It creates a 12GB file by default) – Ricky Beam Oct 24 '18 at 1:22
2

Just to clarify @Manny post since am unable to post a comment.

  • Select Command Prompt. Make sure you run as Admin - right click on the command prompt and select Run as administrator
  • Type 'powercfg -h off' Press Enter.

    powercfg -h off
    

    If it returns an unexpected error

    powercfg -h -size off
    
  • Type 'powercfg -h on' Press Enter.

    powercfg -h on
    

    If it returns an unexpected error

    powercfg -h -size on
    
  • By default the size is set to about 5Gb – nwolisa Aug 6 '15 at 7:08
  • Thank you nwolisa, no error during powercfg -h on and off, just the size was not set ok automatically. I suppose size on and off should fix this problem in the same way I have done with size 75% – Manny Aug 15 '15 at 0:04
1

I'm assuming that hibernation is enabled (powercfg -h on)

Open command prompt as admin

Type: shutdown -h

If nothing happens, there are two posibilites:

  1. you have not installed all drivers or some of them are invaild (most likly this is the problem)
  2. you dont have sufficient free space on system drive
  • 1
    Thank you infografik, but I found the answer myself if you are interested. It is described above. – Manny Aug 15 '15 at 0:06
0

Hibernate option not shown even in settings tab.

On my tablet Olivetti Graphos W810, originally win8.1, now win10, 2GB RAM, worked following theese steps:
1. powercfg /h off
2. freeing 1.5GB on C: (800MB as the file size was not enough :-/)
3. powercfg /h /type full
4. powercfg /h /size off
5. powercfg /h /size 40%
6. enable hibernation in start menu

The type, before manually setting it as "full", was set as "reduced" and hibernation didn't show as available option. Moreover the size before freeing space was too small (405MB), in full type it can be raised, this fact helped too. Bye Daniel

protected by Community Oct 22 at 12:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.