1

[if this is too long you can read from the bottom]

Hello previously i have this Centos7 and it worked fine with the internet connection with static IP.

The problem started when i installed GUI, first i installed XFCE4 (with gdm) and it worked fine, & the internet works too. Only the gdm login page isn't working properly (blank page with cursor), but that's not the case. As I install Mate (with lightdm) to working login page, it affect the network so that i can't connect to the internet. But i can still SSH to the machine from other computer.

ping status

[root@localhost ~]# ping 192.168.5.39 #local
PING 192.168.5.39 (192.168.5.39) 56(84) bytes of data.
64 bytes from 192.168.5.39: icmp_seq=1 ttl=64 time=0.200 ms
64 bytes from 192.168.5.39: icmp_seq=2 ttl=64 time=0.205 ms
64 bytes from 192.168.5.39: icmp_seq=3 ttl=64 time=0.191 ms
^C
--- 192.168.5.39 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.191/0.198/0.205/0.017 ms
[root@localhost ~]# ping 111.94.248.18 #-- google
connect: Network is unreachable
[root@localhost ~]# 

here is the /etc/sysconfig/network-scripts/ifcfg-enp2s0 file

[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp2s0 
TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
NAME="enp2s0"
#UUID="bb980114-13c0-4399-a310-9de54c5ddd75"
ONBOOT="yes"
HWADDR="FC:AA:14:80:C0:B5"
IPADDR0="192.168.5.20"
PREFIX0="24"
GATEWAY0="192.168.5.1"
IPV6_PEERDNS="yes"
IPV6_PEERROUTES="yes"
[root@localhost ~]# 

here is the NetworkManager service status

[root@localhost ~]# systemctl status NetworkManager.service
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: failed (Result: start-limit) since Sel 2015-08-04 05:37:44 EDT; 17h ago
  Process: 865 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=127)
 Main PID: 865 (code=exited, status=127)
   CGroup: /system.slice/NetworkManager.service

Agu 04 05:37:43 localhost.localdomain systemd[1]: Unit NetworkManager.service entered failed state.
Agu 04 05:37:44 localhost.localdomain systemd[1]: NetworkManager.service holdoff time over, scheduling restart.
Agu 04 05:37:44 localhost.localdomain systemd[1]: Stopping Network Manager...
Agu 04 05:37:44 localhost.localdomain systemd[1]: Starting Network Manager...
Agu 04 05:37:44 localhost.localdomain systemd[1]: NetworkManager.service start request repeated too quickly, refusing to start.
Agu 04 05:37:44 localhost.localdomain systemd[1]: Failed to start Network Manager.
Agu 04 05:37:44 localhost.localdomain systemd[1]: Unit NetworkManager.service entered failed state.
Agu 04 05:38:41 localhost.localdomain systemd[1]: Stopped Network Manager.
Agu 04 05:38:50 localhost.localdomain systemd[1]: Stopped Network Manager.
Agu 04 05:39:01 localhost.localdomain systemd[1]: Stopped Network Manager.

and by running nmcli i got this

[root@localhost ~]# nmcli dev status
nmcli: symbol lookup error: /lib64/libgudev-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[root@localhost ~]# 

which seems to be the problem,, i've came across duckduckgo&google and i guess they got the solution here https://access.redhat.com/solutions/1401813 but it only readable by subscribing users (too bad i'm not holding any server business that i can afford the subscribe). anybody got an idea to fix this? Much Thanks

1

I realise that you've probably moved on from this issue but I'm posting the solution that worked for me in case anyone else comes across it.

I had the same error on Centos 7 and managed to get NetworkManager working again by doing the following:

sudo yum clean all
sudo yum install libgudev1-devel

and then startup NetworkManager as usual:

sudo service NetworkManager start
  • I've run into similar issue, when nmcli (and NetworkManager) would fail to run, resulting in default gateway not being set. – Alec Istomin Apr 18 '16 at 22:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.