38

Is there any way to disable Error Reporting in Windows 10 Home? From Windows 7 to 8.1, this was possible under "Action Center"; however, the Action Center is no longer in Windows 10 in the same form as it was in previous versions. It's now just a flyout with quick access buttons and notifications, with no Control Panel entry under the same name where it can be configured. I've searched both manually and using various keywords searching through the settings, but cannot find anything.

In case it's of interest, I absolutely need to disable this, because this action overrides every single debugger on my machine. Before errors are caught up by debuggers, they are caught up by this, essentially making it impossible to code under Windows 10. As such, I was a little surprised to find that no one has raised this question yet.

  • @JMB Home, I think I found a solution manually editing registry keys. There is no option to disable it through any UI I can find in Home and group policy editor isn't available for home, as I'm sure you know. – user72945 Aug 5 '15 at 8:56
  • I'm on Pro, and I found that Error logging can be disabled in Local Group Policy Editor (gpedit.msc), but I don't think that exists in Home. – JMB Aug 5 '15 at 8:58
  • Yeah it doesn't exist in Home unfortunately. I'm verifying my fix, will post as answer if it works. – user72945 Aug 5 '15 at 9:03
  • Control Panel > All Control Panel Items > Troubleshooting >Change settings? – DavidPostill Aug 5 '15 at 10:45
  • @DavidPostill I tried this, unfortunately no, this doesn't disable the automatic search online for solutions. Full-on disabling error reporting in the registry does. – user72945 Aug 5 '15 at 10:47
54

Update
As moab has pointed out, you can also disable the Error Reporting Service through services.msc. I was not able to confirm if this worked correctly myself.

Original Answer
It appears that the only option available to Home users is to disable Error Reporting via modifying the Disabled key in the registry.

Open Regedit. Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting

Find the value named "Disabled" or add a new DWORD value with this name if it doesn't exist. The default value of this key is 0. Double click it to edit, change the value to 1 and save.

This disables the automatic appearance of the dialogue where Windows is searching online to try to find a solution. You are instead shown a dialogue stating that the application has crashed, giving you the option to Debug. However, unlike previous versions of Windows, no error code is provided in this dialogue. The specifics of the error must be accessed through:

Control Panel\All Control Panel Items\Security and Maintenance

Under the tab "Maintenance", you can click "View reliability history", which will show a list of all app crashes. You can then click "View technical details" beside each crash to get more detailed information, such as a the error code(s) thrown from the application on crash.

Screenshots:

Security And Maintenance View

Reliability Monitor

Debugging is still very flaky even after disabling Error Reporting. I'm not sure if this is an OS issue or an issue with the debugger(s) compatibility with the OS mechanics.

  • 8
    It can be disabled in Windows Services also. – Moab Aug 5 '15 at 22:15
  • 1
    @Moab geeze... I should have looked there. lol, I'll edit and add that info. Thanks. – user72945 Aug 6 '15 at 0:11
  • 5
    Find the value named "Disabled" on my machine I also had to set flag DontShowUI to 1 to completely get rid of debug window that appears when application crashes. – Alexey Petrenko Nov 24 '16 at 13:26
  • I did this and it broke my Windows installation. It crashed my PC. When it reset it had to run a repair. Windows is working again but regedit has been corrupted and wont open. – Gary Carlyle Cook Nov 10 '18 at 14:53
2

I noticed on my windows 10 (10 sep 2015) the error reporting service doesn't show up in services.msc, and the registry key is not there. However it still works and shows up as "off" in control panel > security and maintenance after I manually added the disabled key and set it to value 1.

As above, open regedit, navigate to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting

then go to Edit > New > DWORD and name the key disabled, then change it's value to 1.

  • 2
    If you see my answer, I already noted this. This was my original solution. – user72945 Sep 11 '15 at 2:27

protected by Community Jan 13 '16 at 7:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?