1

I have Windows 8.1 Pro. I have been using it for 2 years but I never noticed that Windows apps don't have access to the internet connection anymore. I can use internet for surfing, downloading and other stuff but native apps like Store, Windows Update e.t.c. don't work. It worked fine when it was newly installed. I must have messed up with something. I have attached some screenshots:

enter image description here

enter image description here

You can see Store, Windows Update etc don't have access to the internet. My Windows is genuine and is activated.

Basically, I want to upgrade to Windows 10 and it requires updates installed. I can't install the updates because of this issue. The updates remain stuck at 0.

0

With regards to the the update problem. I also experienced it, I followed this answer, from this question and I solved my problem:

I've found that sometimes you just have to wait, but if it takes a significantly long time try the following:

  • Click the start button and type in services.msc
  • Stop the Windows Update Service.
  • Delete the contents of the C:\Windows\SoftwareDistribution folder
  • Start the Windows Update Service.
  • Try Windows Update again.

Source

Windows update doesn't progress beyond 0 KB 0%

  • I can't delete all of the contents of SoftwareDistribution folder. It says it is open in other file or folder although I have stopped the Windows Update service. I am trying downloading a small update like of 157 KB but it is still stuck at 0%. Plus, the window becomes unresponsive. – Muhammad Talha Akbar Aug 5 '15 at 13:53
  • check again if it's really stopped, it can start alone (that's what happened to me). So when it gives you the error - open the services and verify it's stopped. Maybe you'll have to do it more than one time of deleting-stopping. – arieljannai Aug 5 '15 at 14:39
  • Hey I got the Windows 10 App but not the way you suggested. It was a long process and kinda difficult. But, still I can't see that Windows 10 is being downloaded. It says that you have reserved Windows 10 but there's nothing you can do for now. – Muhammad Talha Akbar Aug 5 '15 at 16:48
  • Ok, that's a good start. Now, you can do two things from what I've tested: You can try my first solution, with deleting the files of the update service, and then it will be forced to check for updates again, or try and run this command from cmd as admin: wuauclt.exe /updatenow p.s. I haven't noticed you didn't had the win10 app, so what I suggested at the answer was to try and force the update itself. – arieljannai Aug 5 '15 at 20:34
  • Thanks for your support! I have Refreshed my windows 8 installation. Now, everything works fine. I downloaded Media Creation Tool; it downloaded Windows 10 and did some other stuff as well but my PC didn't get updated to Windows 10 lol IDK why :'( – Muhammad Talha Akbar Aug 6 '15 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.