21

Just upgraded my Windows 8.1 Pro (Lenovo W540 laptop) to Windows 10, everything went smoothly, all my settings and installed apps preserved and work without a hitch.

The only issue is - Windows's own apps - Calendar, Mail etc. even Windows AppStore - won't launch. When I run them I very briefly see a window flashing and then nothing happens after that.

Any idea what's going on and how to fix it?

EDIT: Seeing bunch of these in Event log: Activation of app Microsoft.WindowsStore_8wekyb3d8bbwe!App failed with error: Access is denied. See the Microsoft-Windows-TWinUI/Operational log for additional information.

  • Based on the error you have sever permissions problems. If doing a Refresh which would mean losing your installed applications, I suggest you go back to Windows 8.1, and making sure those permissions problems were not present there also. – Ramhound Aug 5 '15 at 17:33
  • @Ramhound it worked in 8.1 and it worked (for a while in Win10 as well). but you were right that error was a clue, and I found the solution – Yuriy Galanter Aug 5 '15 at 18:56
  • 1
    This has happened to a lot of people. People have been complaining about since Windows 10 launched. I believe this question is a dupe... but your answer is the best and clearest so far. – Keltari Aug 14 '15 at 21:13
  • I could not write an answer here because of reputation issue. However, I ran into the same problem where all windows 10 apps did not open. I tried so many options I found online and none worked for. What worked for me eventually was running this in PowerShell: Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} from here – Hawk Nov 28 '17 at 2:31
25

Figured it out. For some reason ALL APPLICATION PACKAGES account lost access to C:\Program Files\WindowsApps folder. Once I added it - problem was solved, appstore apps launch normally.

enter image description here]

| improve this answer | |
  • 2
    What?!!! I've searched all day trying to uninstall, reinstall and register Store but not a single webpage said this was the solution. – Daniel Cheung Dec 26 '15 at 9:38
  • 3
    With an obvious note that the "ALL APPLICATION PACKAGES" account name is language specific, this was the solution that worked for me. – Wiktor Zychla Jan 27 '16 at 21:00
  • 1
    Also, check registry permissions. See this Microsoft article: support.microsoft.com/en-us/kb/2798317 – James T Mar 21 '16 at 19:58
  • Can you help me on the Same issue with Windows 10 ? – N.K Jul 10 '17 at 8:05
  • Thank you so much! This helped me get it started again. Now I just have to repair installing apps... – Barabas Apr 11 at 22:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.