21

I recently updated to Windows 10 and I'm quite fine with it.

Except for apps like Mail or Calendar. Upon starting them, they ask me which accounts should be used.

So I'd like to add my Google account, as this is my main calendar.

I press "Add", where it lists several possible services. Upon clicking on "Google", it instantly throws me an error, without prompting me for credentials:

enter image description here

"Just put some happy fluffy clouds here..." - Windows 10 Mail app Designers

This should be the translated error message:

Something went wrong

We're sorry, but we weren't able to do that.

Error code 0x8007042b.

The results of research on the interwebs often recommend to first create a 2-hand-shake-password if turned on in Google. Well, that won't suffice, as I don't have any option to make anything. I just click on "Add Google Account" and the error instantly appears.

How can I get Google services working on Windows 10?

12
  • Do you have 2-factor authentication enabled on your Google Account? If you do then you can't use your account password but instead need to use an application password. The need to do this of course isn't a new requirement in Windows 10 though.
    – Ramhound
    Aug 5 '15 at 17:32
  • I already adressed this in my question. I don't have ANY possibility to insert a username or password, as these forms don't appear. An error immediately interrupts it. BTW I don't have it activated.
    – Trollwut
    Aug 5 '15 at 17:33
  • So I take that answer to indicate you do have 2-factor authentication enabled on the Google Account? You don't have what exactly activated? I am asking these questions for a very specific purpose. Please do your best to answer them.
    – Ramhound
    Aug 5 '15 at 17:35
  • Sorry to be not exactly. :) I do not have 2-factor on. I won't even show a dialog. While clicking "Add -> Google" the error appears.
    – Trollwut
    Aug 5 '15 at 18:48
  • 5
    If he can’t even input his account name, 2-factor auth obviously isn’t part of the problem at all.
    – Daniel B
    Aug 8 '15 at 12:10
12

This worked for me:

  1. Go to your users folder (e.g. C:\Users\John).
  2. Right click, select properties, Security, Advanced.
  3. Click Add, select entity, advanced, search.
  4. Click on ALL APPLICATION PACKAGES, accept. Select Full Control and apply (Ignore errors trying to apply permissions).

Then:

  1. Click on start and type “Services”.
  2. Right click on “Services” and select “Run as Administrator”.
  3. In the Services Window, look for Credential Manager Service and “Stop” it.
  4. Restart the computer and “Start” the Credential Manager Service and set it to “Automatic”.
  5. Restart the computer and it should work fine.

Source: https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-outlook_mail/cant-add-gmail-account-to-windows-10-mail-app/97d4e308-54a8-4afe-b74f-501b1ea0fa2a?page=12

5
  • This looks promising! Immediately after I switched to solely Linux, so can any other Win10 user with my problem confirm this?
    – Trollwut
    Oct 21 '15 at 16:26
  • it works for me!
    – Dima Pasko
    Nov 11 '15 at 11:38
  • This works because after upgrading to Windows 10 or copying files into your user folder from a backup, the permissions are not set correctly anymore. It's best to just apply the new permissions and replace all permissions with inheritable permissions. You may not even have to go past step 4 Nov 24 '15 at 16:26
  • 3
    I was wondering about the security ramifications of this, but the All Application Packages group is supposed to have full control of C:\Users, according to Microsoft.
    – JamesGecko
    Oct 19 '16 at 23:56
  • It works for me too. I am digusted with the kind of bugs and lack of info Microsoft put
    – user4951
    Mar 24 at 6:51
1

I needed to do two things here.

  1. I have two factor authentication enabled for my google account, so I needed to set up a one time password for the Windows mail app. I went into my Google accounts settings. This link worked for me:

https://myaccount.google.com/security

Then go into "App Passwords" (under "Password and sign in method") and follow the prompts to create a password. You choose "Mail" on my "Windows Computer" from the dropdowns.

Leave that password on the screen, I needed it for the next step.

  1. Create an IMAP account.

I couldn't connect to my Google account directly. I got the same error as you. None of the fixes I found on the web worked. So I created a new IMAP account. Go to

Settings (Cog icon) -> Accounts -> Add Account -> Advanced Setup -> Internet Email

Now fill in the details. These are the values I used:

  • Account Name: {any string like "My Gmail"}
  • Your Name: {your name like "Fred Bloggs"}
  • Incoming Mail Server: imap.gmail.com:993
  • Account Type: IMAP4
  • User name: {your gmail address}
  • Password: {the one time password you just generated, otherwise just your gmail password}
  • Outgoing SMTP email server: smtp.gmail.com:465
  • All checkboxes checked

I have used the settings which work for people with a google apps account. If you have problems connecting to the gmail IMAP server, perhaps you need different settings. Google walks you through the settings here:

https://support.google.com/mail/troubleshooter/1668960?hl=en&ref_topic=3397500

Good luck!

6
  • 2
    I do appreciate this doesn't solve getting your calendar synced, but this solution definitely gets mail working. Aug 8 '15 at 8:40
  • Thanks for that info! Unfortunatelly, the calendar is more important to me than the mails. And I would like to connect them accounts "naturally".
    – Trollwut
    Aug 8 '15 at 9:44
  • I have trawled the web for an answer to this one, and there are some suggestions that this is a (Windows) account related issue occurring when you have upgraded from a previous version of Windows. Some people have reported this working fine if you create a new Windows account or reinstall Windows 10...! I can't be bothered to do that so I will be waiting for a fix from Microsoft unless someone cleverer than me works it out first. Aug 9 '15 at 8:44
  • He wants the calendar synced also Aug 9 '15 at 23:03
  • 1
    I'm getting annoyed that everywhere I go this is posted as a "solution". Lets be clear, this is not a solution, this is a workaround. This does NOT fix the issue at hand. Jan 19 '20 at 17:48
0

These steps worked for me whereas all others did not.

Go to your Google Account page

  1. Click Security
  2. Enable 2-factor verification at this step.
  3. App passwords
  4. Mail
  5. Windows Computer
  6. Generate
  7. Copy the generated code.
  8. Done
  9. Open Mail in Windows and click on the cog wheel manage accounts+ add accountOther account
  10. Enter your email address associated with the code, your perferred name and lastly paste the password you copied in step 7.
  11. Sign in

Images showing above steps 1-8 in your google account

Images showing above steps 9-11 in your Windows 10 Mail App

EDIT

I've rechecked this thread and missed how people have generated a password and entered it not how I have done where I was only presented with 3 options.

So, I've done the same but except for the calendar app. Mail worked fine using this method so I thought this might, but no.

So I ran this command in PowerShell

Get-Service -Name "*Credential*" | Format-List -Property Name, DependentServices

This gave me a list of services and any dependent services which came back with

CredentialEnrollmentManagerUserSvc_1c445e

No sign of the other. Which makes me wonder if this is an account problem. My OS is tied to my MS online account.

Then I tried:

  1. Stop-Service -Name "Credential*" -Force -Confirm in PowerShell
  2. Click on Start and type Services. Right-click on Services and select Run as Administrator.
  3. In the Services window, look for Credential Manager Service and Stop it.
  4. Restart the computer and Start the Credential Manager Service and set it to Automatic.
  5. Then the other is greyed out. So I tried Set-Service -Name CredentialEnrollmentManagerUserSvc_1c445e -StartupType Automatic in PowerShell but I didn't have the access to this, even though I'm the only admin.

Not sure what else to try but this info might serve others well.

See screenshot of the services window and PowerShell output for others to check if your results are similar.

Not the answer you're looking for? Browse other questions tagged or ask your own question.