11

Can't type or delete anything. Every so often I'm able to delete a few characters and then type a line or two, but then I'm back to nothing. Backspace moves the cursor backwards, enter goes to the next line, but it's not manipulating any characters, just moving the cursor.

I'm pretty new to IntelliJ and found a few issues that seem similar to this but not the same, most recommend entering "ibus-daemon -rd" in the command line, but I tried this and the ibus-daemon command was not found. Delete will actually delete characters, but I still can't type.

I'm on OSX El Capitan Beta 4, IntelliJ 14.1.4. Using a Microsoft ergonomic keyboard but the laptop's built in has the same issue. Happy to provide additional information but not sure what would help.

Thanks.

1
19

I had the same issue when upgrading to IntelliJ 14.1.4.
If you have the IdeaVim plug-in installed, try disabling it. That worked for me.
Here are instructions if you have never disabled plugins before: Enabling and Disabling Plugins

4
  • Sorry for the absurdly late response, but this did work at the time.
    – spconrad
    Jul 22 '16 at 18:05
  • lifesaver, I cannot comprehend how you found this
    – Greg Price
    Nov 22 '16 at 4:01
  • Or if you don't want disable the plugin, just press the key i in the file and you'll be able to type/delete.
    – Pau Chorro
    Mar 25 '17 at 9:56
  • you saved my dev time! kudos
    – chaosguru
    Aug 22 '17 at 9:40
6

Turn off Vim Emulator from Tools in the intelliJ:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.