I have a problem with my font rendering under Linux Mint 17.1 Rebecca with Kernel 3.17.1. The spacing for monospace fonts is really wrong, some letters are bold and misplaced. At some places the font appears italic and I don't know why. It just looks terrible.

Gnome Terminal:

Gnome Terminal

Sublime Text:


The font settings are set to default:

  • Default Font: Noto Sans 9
  • Desktop Font: Noto Sans 10
  • Document Font: Noto Sans 10
  • Monospace Font: Monospace 10
  • Window Title Font: Noto Sans Bold 10,
  • Text Scaling Factor: 1.0
  • Antialiasing: Rgba
  • Hinting: Slight

Antialiasing and Hinting are not the problem! Also, I did not touch the fonts themselves (I also ran diff).

The problem does appear when I log in with different users, and in cinnamon as well as in i3. I am not using a custom ~/.config/fontconfig file and did not change /etc/fonts/fonts.conf.

Even if I change the font in Sublime to "Times", only numbers seem to be affected.

The problem affects the following applications:

  • Gnome Terminal (using the system's font)
  • Terminator
  • Sublime Text

while it does not affect:

  • Firefox (and other browsers)
  • Android Studio
  • GTK Applications (like Gnome Settings, Abiword...)

2 Answers 2


This is what I found (crossposted: https://forums.linuxmint.com/viewtopic.php?f=47&t=219654):

In Rosa (LM 17.3), after installing the fonts-noto pkg, "Noto Sans CJK TC" becomes the first font to match "monospace" -- command:

fc-match -s 'Monospace'

This is apparently caused by the following block in /etc/fonts/conf.d/90-fonts-noto-cjk.conf (a symlink to /usr/share/fontconfig/conf.avail/90-fonts-noto-cjk.conf):

<match target="pattern">
    <test qual="any" name="family">
    <edit name="family" mode="prepend" binding="strong">
        <string>Noto Sans CJK TC</string>
        <string>Noto Sans CJK SC</string>
        <string>Noto Sans CJK JP</string>
        <string>Noto Sans CJK KR</string>

I copied this file to /etc/fonts/conf.avail and commented out the block in question. Then, changing the corresponding symlink in /etc/fonts/conf.d to point to this new file removed "Noto Sans CJK TC" from the top of the list of fonts matching 'monospace' and the system's default monospace font reverted to what it was before I installed fonts-noto.

  • I am not using this Mint installation anymore, but this sounds like it would have been a solution. So thanks for your answer anyway! Apr 14, 2016 at 7:09

Verify your font match for monospace with

fc-match "Monospace"

For me, it's match with "Noto ... CJK... " something. So I uninstall the package fonts-noto-cjk and solve my problem.

  • This would lead to something like aslamK's answer, I guess. Thanks! Apr 14, 2016 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.