12

I have been trying to run sfc /scannow in cmd but have been unsuccessful. Therefore, after some research on the Internet, I turned to the following command:

DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess

where X indicates the drive letter where the Windows .iso is mounted. (I mounted the .iso file using Daemon Tools)

However, I keep getting the following message:

Error: 0x800f081f

The source file could not be found.

I'm not tech savvy, but after skimming over the dism.log, I found this line that may or may not have something to do with the error.

(p) CSI Payload Corrupt

amd64_microsoft-windows-microsoftedge_31bf3856ad364e35_10.0.10240.16397_none_19381f0c8accd5dd\MicrosoftEdgeSquare44x44.scale-125_contrast-white.png

I really do not wish to reset or refresh Windows because there are just so many programs I will have to reinstall. I would appreciate any help.

On a side note, Windows Update Diagnostic reports that the Windows Update service registration is missing or corrupt, which it failed to fix as well, if this means anything.

16

I've fixed this "Error: 0x800f081f" affecting a PC with Window 10 Pro-32 by running

DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:E:\sources\Install.wim:1 /LimitAccess

Only the Windows 10 ISO downloaded from Techbench and mounted in E: with Daemon Tools worked. Other ISO downloaded with Windows 10 media-creation-tool did not work at all, returning the same error 0x800f081f, even when converted from the embedded ESD format to WIM, using NTlite, and mounted using either Daemon Tools or DISM GUI.

Also all other attempts to fix the error from Windows Update Live had not worked before, always returning same error 0x800f081f, i.e. by using:

DISM /Online /Cleanup-Image /RestoreHealth

Update 08/08/2016: As Techbench link above no longer works please give a try to the following link (note that I have not tested yet if it is the same kind of ISO which was formerly available from Techbench. Please report your results):

https://www.microsoft.com/en-us/software-download/windows10ISO/

  • 1
    The author ran the exact same command, the question itself, is about the error that is generated when they run that command. This also appears to be a near duplicate answer to Noseratio's answer. – Ramhound Sep 30 '15 at 10:54
  • The error in my opinion lies on the fact that not all the Win 10 ISO are the same. The same command run with the ISO downloaded from techbench works, whilst if run with the ISO downloaded by Media Creation tool, it doesnt. Additionallly there's a significant difference from the answer from Noseratio: I had no need to incorporate Windows 10 cumulative Updates, I just had the need to find the right ISO and for this I indeed give my thanks to Noseratio! – a_big_friend Sep 30 '15 at 12:11
  • An answer should answer the author's problem not your own. – Ramhound Sep 30 '15 at 12:28
  • 2
    An answer should be help full to someone else who has the same problem, as the authors has already fixed the issue by re-installing Windows – a_big_friend Sep 30 '15 at 12:34
  • a_big_friend, which iso version did you take on technet ? Cause it doesn't work for me neither and I can't access windows update catalog website to update the install.wim. Please help me, I'm turning crazy right now with all those W10 bugs. – Aeio Much Sep 30 '15 at 14:57
5

I've fixed the same problem by running DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:C:\Users\User\Downloads\Install.wim:1 /LimitAccess against an updated Install.wim with the latest Windows 10 Cumulative Update slipstreamed (KB3081452 and KB3095020 at the time of this post). There's no need to repackage an .ISO.

Basically, I followed the "Add updates to customized Windows" guide from Microsoft itself:

md C:\mount\Windows

Dism /Mount-Image /ImageFile:"C:\Images\install.wim" /Index:1 /MountDir:C:\mount\Windows

Dism /Add-Package /Image:C:\mount\Windows /PackagePath:C:\MSU\Windows10-KBxxxxxxx-x64.msu /LogPath:AddPackage.log

Dism /Unmount-Image /MountDir:C:\mount\Windows /Commit

Those who don't have a copy of the original un-encrypted Install.wim file may find this and this helpful.

Updated, I did another in-place upgrade on two other household PCs, Windows 8.1 -> Windows 10 x64, using the Media Creation Tool and the "Keep nothing" option. After installing all updates (including the latest cumulative update KB3093266), both PC failed the "sfc /scannow" test and the "dism /Online /Cleanup-Image /RestoreHealth" recovery, same error 0x800f081f.

So, I repeated the procedure described above, this time using a Windows 10 ISO from TechBench and slipstreaming the KB3093266 MSU into its install.wim. Problem fixed.

Updated, the issue re-surfaced after upgrading to Windows 10 Version 10.0.10586.0 (November 2015 Update + latest cumulative update). This time, I simply downloaded the latest ISO from TechBench, mounted it and executed DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:E:\Sources\Install.wim:1 /LimitAccess, then sfc /scannow. Apparently, there's no need to slipstream the latest cumulative update.

Updated, the issue re-surfaced once again on a different PC. This time I coudn't find the ISO (has TechBench gone?), so I had to use the Media Creation Tool, create a USB drive installation, then convert install.esd into install.wim:

dism /export-image /SourceImageFile:d:\sources\install.esd /SourceIndex:1 /DestinationImageFile:c:\temp\install.wim /Compress:fast

Then repair the image using Windows Update as backup (i.e., without /LimitAccess):

dism /Online /Cleanup-Image /RestoreHealth /source:WIM:C:\temp\install.wim:1.

Then repair the system files:

sfc /scannow.

  • Can anyone else confirm this as well? – Skipher Sep 28 '15 at 13:50
  • @Skipher - You are the only one who can confirm if this works or not. – Ramhound Sep 30 '15 at 10:56
  • My answer to this question states that I no longer have this issue as I have chosen to reinstall Windows. – Skipher Sep 30 '15 at 13:04
  • @Skipher The TechBench ISO is good. It's confirmed. See answers above by a_big_friend. – Richard_G Jan 11 '16 at 16:18
  • 1
    I can confirm this is still valid. Had a computer die on me after using Disk Cleanup to try to reclaim some space (pro tip: don't do that). Only thing for me is dism refused to work offline and wouldn't find the replacement payloads. So what I ended up doing was running dism /ScanHealth, looking at the logs, then with the wim image still mounted, manually copying the offending files over (i.e. from c:\mount\Windows\Windows\winsxs\<component>\* to c:\Windows\winsxs\<component>). – lc. May 29 at 4:21
4

Don't use the parameter /source:WIM:X:\Sources\Install.wim:1 /LimitAccess. Windows 10 has version 10.0.10240.16384 and the corrupted file has version 10.0.10240.16397. So the file is not part of the Install.wim. Without the /source parameter DISM will download the corrupted files from WindowsUpdate and replace them.

  • 2
    I've used the /source parameter because the command without a specific source also gave me the same error, and I was hoping to repair it with an .iso file. What can I do to overcome this error? Also, is the error message "The Windows Update service registration is missing or corrupt" related in any way to the problem you addressed? Thanks. – Skipher Aug 6 '15 at 16:26
  • 1
    inject the older UpdateRollup support.microsoft.com/en-us/kb/3074683 into the install.wim (woshub.com/integrate-windows-updates-into-windows-8-image) and now use the /source command to point to the new WIM. Does this work? – magicandre1981 Aug 7 '15 at 4:14
  • I ended up doing an in-place reinstall of Windows 10 because of the frustration, but thank you for providing this new idea! I have never heard of it before, and I will definitely try it the next time my Windows acts up. Thank you very much. – Skipher Aug 7 '15 at 4:25
3

I had the same problem, tried with the other solutions in this post but none worked.

This one worked:

  1. download Windows 10 ISO from Techbench
  2. mount the iso
  3. assuming D is the drive letter of the mounted iso, run the following in an elevated command prompt:

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess

  • link isnt working, please update the link – Shan Khan Jul 30 '16 at 17:49
0

In the end, I simply did an in-replace reinstall of Windows. I did not want to lose all my programs, so I chose not to refresh or reset Windows, and there was no remaining method of repair that would work.

-1

OK, thanks for all the instructions and hints on this topic.

I did get my DISM problem solved with following steps:

  • having Windows 10 ISO 1511 10586.0 (maybe .493?) already on an USB stick

  • first copied the E:\sources\install.esd into C:\

  • then converting the C:\install.esd getting it into ...\install.wim and copied it into C:\

  • then running the -> DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:C:\install.wim:1 /LimitAccess

  • finally noting that a successful Cleanup done

Great! Next I can once again go on chasing my original problem -> Windows 10 Anniversary Upgrade error 0xc1900101 - 0x30018 referring to SYSPREP , let's see what now happens with it ...

protected by Community Dec 5 '15 at 10:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.