2

I'm trying to shadow a console session. For now this works fine when using shadow ID on the commandline directly on the Windows 2008 R2 server. So I'm able to view the remote session of the console in this way.

When I try to do the same using mstsc this does not work and I'm getting the message 'Access is denied' while I think all rights are OK and I'm not using the multi-monitor option on the Display tab of mstsc.

The mstsc session is being started from Windows 7 SP1. Example:

mstsc /v:10.1.1.1 /shadow:4

I also already changed some group policies to enable

Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections\Set rules for remote control of Remote Desktop Services user sessions

and

Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\Set compression algorithm for RDP data

The two changes above made the shadow directly from the server's commandline possible but apparently I still got 'Access is denied' after getting it to work on the server. Anyone has another idea on this?

2
  • Can you please try /admin ? It might be a long shot, but still worth a try. – cdavid Aug 7 '15 at 17:55
  • Already tried that :) – Nicholas Aug 7 '15 at 20:10
0

This is caused by users running in multi-monitor mode. If they log out, uncheck the checkbox on the Display tab which says "Use all my monitors for the remote session" as so... and then log back in, then you will be able to Remote Control their session.

There is unfortunately no work around for this issue.

1
  • The question says “I'm not using the multi-monitor option on the Display tab of mstsc.” – Scott Oct 15 '18 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.