1

I have been using windows 10 for a week now without any problems. Today windows 10 installed "eGalaxTouch - Other hardware - USB Touchscreen Controller(A103)" through windows update. It has turned my touch screen into a mouse.

Edit: By acting like a mouse I mean that, I can not use touch gestures, option to open on-screen keyboard has disappeared, and scrolling the web browser's page results in selection of text instead of scrolling. Also it lists under 'Mice and other pointing devices' in the device manager.

Edit 2: Also touchscreen driver is not listed on my laptop's (HP ENVY TouchSmart 15-j137tx ) website.

This driver does not show in 'installed updates', so I can't uninstall it. I tried deleting the driver from device manager but it does not work.

How do I revert to older touchscreen driver?

1
  • @Steven, I have updated the question to answer your question.
    – Hassan
    Aug 6 '15 at 18:11
0

Driver rollback from the device manager worked. Older microsoft HID-complient drivers were installed and everything is working perfectly now.

Edit: The screenshot below was taken after the rollback. People facing the same problem will need to rollback the touchscreen driver listed under "Mice and other pointing devices". Roll_Back

2
  • I checked every setting in device manager and the HID-compliant touch screen properties has vanished. I am seeing eGalaxTouch - Other hardware - USB Touchscreen Controller(7926) under my update history. When I go to click to remove the update it isn't in the list. The only updates that are there are those from Microsoft. Aug 6 '15 at 20:27
  • The screenshot in the answer is after I did the rollback. You will need to go to "Mice and other pointing devices" and rollback driver for touchpad listed there.
    – Hassan
    Aug 6 '15 at 20:30
0

I had the same issue as nonameswereavailable. The HID-compliant touch screen driver was hidden and apparently was disconnected from the computer after the update, you could only see it from device manager >> view hidden devices. There was no rollback available (since it was disconnected, I think).

I ended up restoring my system to before the update happened, and then followed this to stop installing drivers automatically, and this to stop updating automatically too, which might be a bad idea. We'll see.

0

In my case the rollback option was disabled. I was able to restore the old (and correct) behavior by using the option "Update Driver software -> Browse my computer for driver -> Let me pick from a list -> USB Input Device"

Not the answer you're looking for? Browse other questions tagged or ask your own question.