1

I am running Libre Office 4.4.3.2 on Win 8.1, recent Thinkpad, with a Samsung ML-2850 series printer connected via USB. Whereas printing from WordPad, Firefox, ... works nicely, I cannot print from Libre Office (very simple text-only documents tested from Writer, Impress, ...)

-> printer signals an error (on this model this is only a red lamp, no further information), and it simply does nothing anymore (does not even documents from other applications that had been working before) unless I pull the power line. No error message on computer, no document in print queue.

I tried updating the driver, no change. Searching, I found suggestions for Linux which I could not translate to Win-Libre Office (changing printer language PDF/postscript, the described menues simply did not exist). I tried to set paper size to the (actually loaded) A4 instead the default letter in multiple submenues in Win and Libre, no change.

Any idea?

1

Too stupid. The basic problem was, that the default page size was letter, and that LO refuses to print to A4 (as selected by all instances of printer property options I could find - within WIN printer defaults, LO, ...) - UNLESS LO was told to actually use the selectd paper size: Printer -> Options -> USE ONLY PAPER SIZE FROM PRINTER PREFERENCES! Unfortunately, Libre Office does not remember this choice (to actually use the selectd paper).

Second "unfortunately": To avoid the wrong paper size in the first place, it seems to be somewhat tricky to change the default page size of new documents (at least for s.o. who decided to test LO a few days ago). For instruction/further links: http://ask.libreoffice.org/en/question/10973/permanently-set-default-page-style/. However, basically the Templates folder does not exist, and the Tools/Options/Paths (Templates path) points to a non-existing location (left over from LO 4 after automatic deinstallation by LO 5?).

0

LibreOffice 5.0.0.5 is released 8/5/2015 upgrade and see if the problem persists.

  • Along the same vein, trying OpenOffice is also an option. – Lyrl Aug 7 '15 at 16:44
  • @Lyrl They haven't updated OpenOffice since Released 2014-08-21. They no longer seem to be interested in updating there stuff which is why I gave up on them. – cybernard Aug 7 '15 at 17:18
  • Yes, problem persists in 5.0.0.5 :-(. For details & workaround see answer above. – Martin Aug 20 '15 at 19:20

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.