I installed Windows 7 fresh and installed SP1. Now, when I try to check manually for Windows Updates it just hangs on the Checking for updates screen.

Windows Update dialog on hang

I tried running the tools in How do I reset Windows Update components?, but this did not fix the issue either:

No matter what I do it just hangs on the "Checking for updates..." screen and goes no further.

  • Might be a similar issue to this? superuser.com/questions/962070/… – Jake Fisher Oct 20 '15 at 2:13
  • 3
    I recently had the same problem and solved it by shutting down windows and then restarting it. A mere reboot was not enough. Only at shutdown it started installing updates and then the next boot it found the next set up updates. – Hennes Dec 18 '15 at 23:19
  • Neither magicandre1981 nor Moab's answers assisted me. After following both procedures (on a virtualbox I reset back to the same snapshot) I still had the hung update search. I did find a fix though! I have no idea what update got everything sorted out but using this sledge hammer I was able to get a bunch downloaded and installed. Then did a normal windows update and it had another ~30 and I was all up to date again :) – HodlDwon Apr 23 '16 at 22:48
  • See also OS/2 Museum: Updating Windows for an anecdote. – a CVn May 27 '16 at 13:14
  • 1
    If you're on Windows 8.1 and looking for a solution, this worked for me: overclockers.com/forums/showthread.php/… TL;DR: install support.microsoft.com/en-us/kb/3102812 and support.microsoft.com/en-us/kb/3173424 , reboot and re-run Windows Update. – blade May 13 '17 at 16:20

13 Answers 13

up vote 510 down vote accepted
+50

Fix

Microsoft released a Windows Update Client Update which is part of the July 2016 Update Rollup to fix the long hang at Windows Update scan.

This update contains some improvements to Windows Update Client in Windows 7 Service Pack 1 (SP1). This includes the following:

  • An optimization that addresses long scan time for updates that's reported on some computers.
  1. Download:

  2. Stop Windows Update service. This speeds up the setup of MSU updates and the useless steps from Moab are not required (reboot causes that the WU service is stopped until it gets started via trigger when Internet is available). This can be done from the command line, or from the Service Manager window.

  3. Try the downloaded update and see if it speeds up the installation of Updates.

To be able to install the update you first need to install the April 2015 servicing stack update for Windows 7 and Windows Server 2008 R2 update (again, stop WU service before trying to install the MSU).

Download (April 2015 servicing stack update):

Workaround 1

If this is still not helping to search for new updates, use WSUSOffline to get all the updates.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Journeyman Geek Dec 22 '16 at 23:53
  • Windows 8.1 has a similar problem, and the solution is basically the same: download an update to the Update Client and manually apply it. – stiemannkj1 Jan 1 '17 at 1:06
  • 1
    For the record, here are the steps that fix my problem (32-bit Windows7 SR1) that stuck at "Checking for updates" or "Preparing to install". (1) run "net stop wuauserv" from cmd.exe to stop Windows Update service; (2) download and install "April 2015 servicing stack update" (Windows6.1-KB3020369-x86.msu") mentioned in this answer; (3) download and install "Windows 7 SP1 Update Rollup" (Windows6.1-KB3179573-x86.msu); (4) download and install the "Windows Update Client Update" (Windows6.1-KB3172605-x86.msu) mentioned in this answer. Reboot Windows whenever asked by the installed update – tdwong.star Jun 26 '17 at 1:40
  • I couldn't find the package for download... links are dead – JobaDiniz Jul 1 '17 at 21:02
  • @JobaDiniz for me they work. you can also search for them here: catalog.update.microsoft.com/Search.aspx?q=KBXXXXXX. Change the KBXXXXXX to the real KB number like catalog.update.microsoft.com/Search.aspx?q=KB3172605 – magicandre1981 Jul 2 '17 at 7:08

This issue has come and gone over the years with different fixes along the way, so here is my updated guide to this issue as of this date January 5th, 2016.

Check the EDIT section below, there is a much faster way to fully update Windows 7 SP1 after a clean install now.

This is what I do when I reinstall Windows 7 with SP1 or have issues with Windows update stuck on checking for updates.

If Service Pack 1 is not installed, install it before following this guide.

Choose

windows6.1-KB976932-X64.exe

for 64bit W7 or

windows6.1-KB976932-X86.exe

for 32bit W7

Download KB-3138612 and save it where you can find it later

Download SUR Tool save it to same place

Restart the PC and disconnect from internet before Windows loads, this is important because at every boot windows will check for updates in the background and this will start the checking for updates hang all over again and will prevent the install of the downloaded packages until it finishes checking, so disconnecting from the internet before Windows loads prevents this.

Once booted install KB-3138612, if reboot is required do so and stay disconnected from internet.

Now install the SUR Tool package, this is a big package and will install many updates along with cleaning up and repairing the Windows update store. It will also cut down on how many more Windows updates will need to be installed later.

After install of SUR package reboot, connect to internet and do a manual Windows Update, it should work much faster now. Even after these fixes I have seen some W7 PC's take up to an hour to finish checking for updates if launched from Control Panel manually.

If you have other Windows updates issues and the 2 updates above are installed, download this Microsoft Windows Update fixit tool (right click "save link as") run it and select aggressive mode to completely reset Windows updates. Reboot and try Windows Updates from the Control Panel again.

Update: Microsoft has released a huge update rollup for Windows 7 SP1, this is similar to a service pack but they are not calling it that. This will make it Much faster to update Windows 7 after a clean install, no more Windows update issues and many reboots. This update rollup will bring the system current to patch Tuesday of April 2016.

This is not being released through Windows Update, you have to use Internet Explorer to get it, open IE and go to this address

http://catalog.update.microsoft.com/v7/site/home.aspx

Type in the search box 3125574 and hit enter key.

enter image description here

Now you will see all versions of this rollup, select the one you need and download it somewhere you can find it later. Also use the Windows Update Catalog page to **download and install this update first, 3177467, it is a pre-requisite for the rollup, then install 3125574, also be sure to be disconnected from the internet when applying these updates.

enter image description here

  • 1
    This solution worked after the both Windows Update Automated Troubleshooter and the Windows Update Update failed I had tried the following instructions without any apprent luck. I'm including them here in case they were still a part of the solution. answers.microsoft.com/en-us/windows/forum/all/… – user779756 Jan 9 '16 at 4:13
  • 2
    Thanks, this worked for a DVD install of Windows 7 SP1. On a 4GHz eight core 16GB on an SSD it took about ten minutes to find the updates (in case anyone else encounters this scenario and is wondering how long to wait). – John Jan 16 '16 at 11:45
  • 2
    I confirm this method works. Since some time KB3102810 is the only way to solve the Windows Update stuck at searching for updates problem but recently after installing 100 updates or so the problem returns. Your suggestion of running SUR after KB3102810 worked for me. Thank you. – Hatoru Hansou Feb 9 '16 at 0:46
  • 1
    The SUR Tool also worked where nothing else did on Windows Vista SP2. It seems to repair the Catroot2 folder as part of the repair. If I were working as a technician, I would have the SUR Tool in my toolkit at all times and apply it to any damaged or suspect Windows installation. It's a HUGE shotgun blast of fixes. – Syclone0044 Mar 7 '16 at 10:31
  • 1
    This worked for me, although rather than disconnect the network, I disabled auto updates. I had previously tried Microsoft's troubleshooters and various other solutions I found on the web, with no luck. – boot13 Apr 29 '16 at 15:15

I found that Microsoft had a fantastic tool for fixing their own updates. Running the "Windows Update Automated Troubleshooter" package cleared out all of my issues with updates.

See Windows Update: FAQ. Scroll to "What can I do if I’m having problems installing updates?"

Or use the download link.

  • 1
    Seems like the website changed to support.microsoft.com/en-us/gp/windows-update-issues – Jake Fisher Oct 20 '15 at 1:51
  • 1
    Tried that updated URL as in Jake's comment, but it didn't fix this. – RichVel Dec 13 '15 at 17:47
  • Unfortunately, the inbuilt helper and the website download of Mr. Fixit did nothing for me. However after removing app data and optimising (using bit-defender) it instantly started updating - worked with windows 10 update. I guess one should try to remove cached data as well where possible. – Ross Dec 21 '15 at 9:36
  • 3
    I tried the Windows Update Troubleshooter tool. It shows 0x80080005 error. Anyone know how to fix it? pbs.twimg.com/media/CtV1EhUVIAAjRVi.jpg – kamleshrao Sep 27 '16 at 8:32
  • Before you use Windows Update Troubleshooter, make sure you have good backups. This tool froze Windows 7 while "fixing" it and destroyed it so bad that I had to fully restore it from backup. – Martin Sugioarto Dec 18 '16 at 21:46

This is for those of you (like me) who have tried every solution you could find with no joy. The following process worked for me on a client's extremely stubborn HP DV6 reloaded via factory image w/SP1 that didn't respond well to the other solutions I tried (although they are part of the solution). This is the exact order I used to achieve success.

  1. Perform a Clean Boot

    Run msconfig.exe and choose "Selective startup", making sure that "Load system services" is checked and "Load startup items" is not checked.

    Go to the "Services" tab, click to select the "Hide all Microsoft services" check box (at the bottom of the window), and then click "Disable all".  Click "OK", and then click "Restart".

  2. Run "Windows Update" – click "Change settings" and set it to "Never check for updates".

Reboot

Manually apply the following updates in order.

KB3020369
KB3172605

In my case I had attempted these previously, but it appears that the order along with the clean boot and Windows Update setting were critical.

  1. After the above updates are installed, run msconfig.exe again and this time choose "Normal startup".

Reboot

  1. Run Windows Update and you should be presented with the expected slew of updates (in my case, 198) requiring installation. Proceed to install them.

  2. If you like you can change Windows Update settings back to automatic when you've finished applying updates.

  • you posted no new information. The July 2016 update rollup is already posted as solution. – magicandre1981 Oct 3 '16 at 12:23
  • 1
    All due respect, but If the update client had fixed it for me I would have stopped there, upvoted your post and moved on. To be fair, I won't rule out the possibility that I got lost somewhere. Perhaps if your answer was a bit more concise? A "Fix", 3 Alternativee "Fixes" and 3 Workarounds later I still had the same problem. This is what fixed it for me (in order and exactly) If the July 2016 update fixes it all by itself, why not shorten you answer to a more manageable size? – Elder Geek Oct 4 '16 at 11:39
  • 2
    And now MS has endorsed this :) . Thanks for the link to HTG (I'm not affiliated - just struggling with the same problem!) – cxw Nov 20 '16 at 17:03
  • 1
    Followup: I did this, but then had to also do the InfoWorld procedure to get past "Checking for Updates." – cxw Nov 20 '16 at 19:21
  • 1
    This worked for me, reinstall of oem windows 7, just hanged, tried the rollup 2016 but no luck, I think it was the oder it was done and turning off the updates THEN rebooting.....Follow this and all should be good....Thanks – Mikeys4u Dec 22 '16 at 13:06

I had the same experience - Windows would check for updates forever. One processor core would max out and one of the svchost tasks in the taskbar devoured a gigabyte of memory.

I decided to install updates manually, and the briefest of googling found the Windows Update Downloader. I used this to manually download 106 security updates.

I then installed each of these updates manually. One at a time. Using herculean amounts of patience.

Some of the updates would do similar to Windows Update itself - when I ran the update, I got a window which had a title of "Windows Update Standalone Installer", with a "doing stuff" type progress bar (rather than one which progresses just once from left to right) below the phrase "Searching for updates on this computer", with a cancel button in the bottom right.

Clicking cancel did nothing. In order to kill it I had to close three tasks in Task Manager or restart. But I observed that after a reboot, the update which got stuck would then install successfully.

So I grinded my way through the updates, installing two or three at a time then rebooting when I saw the window I described above for more than 20 seconds with no progress. Some of them popped up a message like "this update is not required for your computer", so I just deleted those without installing.

When I finished installing all 100 or so updates, I tried running Windows Update again. One core went to 100%, the svchost task went to a gigabyte of memory.

I left it for a bit, then went to shut the computer down in disgust. And the little yellow Windows Update shield appeared on the shutdown button!

I let it install the 7 or so updates, then powered it back up. I left it a while, then once again the little yellow windows update shield appeared on the shutdown button! This time there were 50 updates.

Third time round there were 79 updates.

And after that, I ran the Windows Update thingy, and it worked!

I'm not arrogant enough to say that this will fix your problem. All I'm saying is that this fixed your problem for me. Best of luck!

In my case the download progress was stuck at 0%. I solved the problem in the following way (as suggested here):

  • Stop the Windows Update and Application Experience services (if they don't stop, disable them and then reboot)

  • Delete everything inside C:\Windows\SoftwareDistribution

  • Restart Application Experience and Windows Update services

  • Reopen Windows Update and let it check for updates

Simple solution: Open Windows Update, go to change settings, make sure it's set to install updates automatically, change the Install new updates time to the next hour (as opposed to the 3:00).

Set the computer to never sleep when plugged in. It may take up to two hours for the updates to start, so be patient.

  • 2
    How would this solve the problem? It would simply move the hang one hour into the future. – Chenmunka Sep 4 '15 at 11:50
  • actually this fixes the problem, seems that automatic updates are working but manual are not. – Karim Jan 5 '16 at 22:25
  • I have to confirm that this apparently does work. As long as you have opted for a non manual update check, windows update works OK. I configured "Check for updates but let me choose whether to download and install them" which disables the option of when you want to check fro them, but it should happen inside 10-20 minutes. Have no idea what MS figured with this. – mkey Apr 8 '16 at 16:08
  • 1
    This method dows not allow to select what updates you want to install. I don't want Defender nor Malicious Software Removal Tool. – Sopalajo de Arrierez May 8 '16 at 9:21
  • 1
    I tried all of the steps listed by the accepted solution except the non-official updates workaround and this is the solution that finally got the first round of updates installed. Ugh. – Compholio Jun 24 '16 at 18:37

This is for PC/laptops with relative little memory (3 GB or less)

After trying without success

  1. Antivirus scans (multiple)
  2. Registry fixes
  3. Windows Update troubleshooter
  4. Installing the latest version of windows client

My fix was simple.

Check your power options

If your PC/laptop is using a lot of memory, you won't be able to use it while checking for updates and even if you leave it whenever you "come back" to check it's still checking for updates, even after leaving it for several hours.

Explanation:

The problem is your power settings put the PC/laptop to sleep thus stopping the update check and starting all over when you wake it up (thinking it was checking all the time you left it)

Solution:

Change the power setting to put the computer to sleep to never (you can change it back when updates are successful)

Control panel -> Hardware and Sound -> Power Options -> edit plan settings

Put the computer to sleep -> Select never -> save changes

Then check for updates again (leave it for several hours if you only have 2 GB memory).

  • The power options is a useful tip for slow operations, but magicandre's answer actually speeds up the Check for Updates, which is more useful here. – RichVel Dec 14 '15 at 12:59
  • The important thing is that you leave windows update running for a long time. I have a pretty high spec machine and it still took over an hour at high I/O and processor load for it to show the "install updates" button. Theres some really inefficient microsoft code in there somewhere. – Phil_1984_ Jun 23 '16 at 9:11
  • I just had a case where a quad-core / 8GB PC took over 24 hours in the working-out-required-updates step without finishing, and others have had days... Since there's a limit to patience, @magicandre's solution (and particularly WSUS Offline Update) seems best. – RichVel Nov 25 '16 at 11:33
  • @RichVel and others who don't think this is THE solution, that's maybe right. For me it was the solution, the OP didn't show his specs (quad-core 8gb pc). This answer is a suggestion I read myself, tried it and when it worked I posted it here. – davejal Nov 25 '16 at 23:35

Recently I restored an -I think- 2010 notebook recovering it to its initial system image, a 64bit version of Windows 7 (without SP1). I uninstalled some craps coming with the notebook and installed some basic purpose software like 7zip, VLC, an antivirus, etc. (all free software from secure sites or paid versions not cracked ones just to be clear). I made the update to SP1 (appeared after some reboot among Windows Update list after the very first ones I had installed) and returned the PC to the owner. After a week or so, the person who asked me for help told me he noticed that every time he checked for windows updates the process went on forever even waiting for long time for the task to complete. At first I thought of malware despite the person insisted it was not possible and that it happened since the beginning, anyway I decided to restore the PC again to its original system image just to be sure. I made the same things I did the first time but, instead of returning the PC immediately, I decided to keep it for a while using it just to surf the web a little, watch some videos and listen to music in spare time... Meantime I launched Windows Update to search for updates and, indeed, I noticed that the process went on for very long time never finding anything nor stopping and coming to an end, just as the owner had told me.

I tried solving the problem following almost every reply to this question, and the duplicate one here on SuperUser without solving.

Then I tried following cluberti comments on this and even haley_joel_osteen ones on Reddit still not solving the problem.

I tried several of the fixes listed on this Microsoft support thread and still nothing worked.

Last but not least, I also tried following answers to similar problem on a couple of Microsoft community answers (1 , 2) and even one on tom's hardware BUT, after all this, NOTHING: I still didn't manage to solve the problem!

I don't know if the fact the OS language wasn't American/English has to do with this the fact all listed tries didn't solve the problem... Anyway, since I saw Windows Updates worked at the beginning, I decided to restore the PC to its original system image again to try to install the updates one by one trying to understand WHEN (and hopefully even why) the problem manifested itself...

COMING TO SOLUTION:

TMLSS: In the end I noticed Windows Update stopped working just after SP1 update (KB976932) was installed and I solved every issue by following these steps:

  1. Go to Control Panel > Programs > Programs and Functionalities > Installed Updates, search for and uninstall SP1 update KB976932. (I remember I uninstalled KB958488 update too, but I don't think that's really necessary)

  2. Download that same update "manually" from Microsoft Update Catalog, going to http://catalog.update.microsoft.com/v7/site/search.aspx?q=KB976932 (MUST MANDATORILY USE IE FOR THIS) and choosing the one which correctly suits the operating system (32 or 64 bit).

  3. "Manually" install the downloaded update to Windows 7 SP1 (I noticed that the size of the "manually" downloaded update was about 6 to 12 times as big as the one installed automatically by Windows Update before).

This should just be enough but, to be just sure, I remember I then installed also KB3172605, KB3020369 and KB3125574 updates.

And that's it, this finally solved the problem in my case!

  • A downvote on a possible solution to this problem? (Really? I'd like to know why) Well anyway, I know this is a working solution to this issue because I solved it that way and I think someone else could be happy to find it (I certainly would have and would have saved a lot of my spare time trying to figuring it out too) so I gonna keep it here. – danicotra Oct 30 '16 at 20:10
  • @Benoit Blais another SuperUser user suggested a simpler solution -I haven't possibility to test but I want to report- which is: disable NIC card first (start, run, ncpa.cpl), install patch Windows6.1-KB3020369-x64 and Windows6.1-KB3172605-x64 without rebooting between them, then enable the nic and reboot. BINGO – danicotra Nov 13 '16 at 11:10
  • 3125574 is a huge update rollup for Windows 7 SP1 (huge meaning 475MB), which updates Windows 7 to April 2016. It includes every critical update since Service Pack 1. So no wonder its inclusion in this solution cures the problem. But it doesn't exactly help isolate the cause. And, should it be relevent to anyone, I used Firefox 39 to download it, not Internet Exploder. – Ed999 Jan 18 '17 at 18:56
  • @Ed999: the main point in my answer is KB976932 update and that's the one of which I told it needed to be downloaded with IE. I told I then installed also KB3125574 just to be sure (it certainly couldn't had hurt) ...and I'm quite sure I too was able to download that one without using IE. – danicotra Jun 10 '17 at 8:28

This is probably specific to VM's. 1) Increase cores from 1 to something higher.

For me this had an immediate and dramatic effect on both CPU activity and RAM usability. Almost lost among the comments between KB hotfix/update answers, this passing mention in @Eugene K's comment needs an answer in its own right.

Note: I prepared this as an answer to Windows Update doesn't work and consumes 100% of CPU (Win7 SP1), which is marked a duplicate of this one (though this one doesn't actually mention 100% CPU). I find I am unable to post my answer there as the answer controls are missing, perhaps related to marking it as a duplicate, so this seems the next best place as folks trying to solve the 100% CPU question get given the link here.

There are several different issues with Windows Update, which, superficially, all sound the same. To be clear: this particular question is about Windows Update consuming 100% CPU without anything seeming to happen, and remaining in that state over a long period of time. My Windows 7 VM was in just this state. Task Manager showed 100% CPU being consumed by svchost.exe, the generic "parent" process Windows uses to "host" and run individual services. By right-clicking svchost.exe and choosing "Go to service", I was able to see which service was the culprit, and the culprit was wuauserv, the Windows Update Automatic Updates service.

I tried turning of IPV6, something suggested among the answers (which I thought I'd already done on all machines after other issues) but it made no difference in this case. I was loth to start picking and choosing KB hotfixes and updates, when there are a number of similar issues with Windows Update; I'd much prefer it to apply all the updates itself, in the right order, if there's a way to get it in a state where it will do that. I left it for 24hrs and when I looked again it was still at 100%—and, moreover, the update history showed that it had not even installed a single update in that time. The last one had completed the previous day, over 24hrs ago. A couple of restarts made no difference: it just went straight back to 100% CPU.

Turning then to the question of Hyper-V, I looked and found where you can configure the number of processors for a VM. The setting is greyed out when the VM is running, so you must shut it down to change the setting: enter image description here I increased the number of processors from 1 to 2 and saw an immediate change: the VM now actually seemed to be doing something. Both CPU and memory usage rose and fell constantly. I also noticed that the VM seemed to be able to utilize more of the memory allocated to it: previously, when stuck at 100% CPU, it had been using 2G out of 4G bytes of RAM, whereas now, rising and falling, it was using up to 3G. I shut it down and increased the number of processors again, from 2 to 4, and saw a corresponding increase in the effects: a great deal of continuing activity in Task Manager, different in each of the 4 processors, and again, an increase in the amount of memory it could utilize, still rising and falling but now approaching the full 4G allocated. It seemed to be tearing through the updates now. And CPU usage, rapidly zigzagging too, was now typically around 25%, meaning from this point on the machine became far more responsive and usable while updates were being processed.

To recap, there are a number of different problems that can cause Windows Update to hang or run slowly, and Microsoft have published a variety of hotfixes and updates in this general area. So any time this comes up, it's quite likey there's more than one contributing factor. In any given case, upping the number of Hyper-V processors configured may or may not be the complete answer, but there's no doubt that doing so brings a dramatic improvement in the machine's ability to utilize both CPU and RAM.

I had a similar problem.

Per this answer:

...reset all the Windows Update, that way it will start anew. You can use this script. Run it As Administrator, use option 2 and 3, and when finished restart the PC.

If that does not help, I would suggest you trying to delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersio‌n\WindowsUpdate\Auto Update\RebootRequired (export it first to have a backup) and restart the PC again.

I had the same issue with an older Win7 laptop I hadn't booted in a year. After trying the above solution(s), especially installing KB3020369 and KB3172605, I finally relented and used the super-duper-fixit-all patch on Microsoft's "answers" site.

It, incidentally, installs both of the above KB patches, in a 6 step process.

It requires a total of 6 reboots, but is otherwise pretty painless (1/2 hour). This was the only thing that solved the problem for me, after hours and hours of searching and testing.

Here's the link (links to Microsoft):

MS Fix Checking for Updates, Win7

There are various reasons this can happen. However I have lately found that this happens on every fresh windows 7 install, where it didn't used to.

The causes:

  1. Windows 7 performs a silent update to windows update component the first time it gets an internet connection. The current version of this silent update as of 2016-12-15 is the one causing the problems. This update is very badly designed and will easily break your windows update component if while it is installing you open the "Windows Update" program, or internet explorer, or install anything, or several other things.

  2. Even if the update goes without a hitch, there is also a secondary and known issue where there are just too many old updates clogging up windows update.

Solution:

None of the solutions listed here work for issue 1. The troubleshooter will find a bunch of problems that it claims it fixed, but it didn't. Every time you run it you will get more problems listed as fixed with no actual solution. reinstalling windows update tool doesn't work either. As for issue 2, that one just requires you to manually install some specific updates which also isn't mentioned here.

The only solution i have found is

  1. Reinstall windows, do not yet connect to internet.
  2. update the update agent manually and reboot. https://support.microsoft.com/en-us/kb/949104
  3. Disable auto updates
  4. install the april 2015 service stack update KB3020369 and reboot https://www.microsoft.com/en-us/download/details.aspx?id=46817
  5. install the july 2016 update KB3172605 and reboot, wait 15 minutes after rebooting to do anything. https://www.microsoft.com/en-us/download/details.aspx?id=53332
  6. connect to internet
  7. install standalone offline internet explorer 11 and reboot.
  8. enable auto updates and use it to install remaining updates.

you should now be able to use windows update and your computer.

Note that steps 4 and 5 are supposed to go together in that order and are part of the official MS fix for this issue. MS says you should wait 10-15 minutes after rebooting before doing anything else.

protected by Community Dec 27 '15 at 18:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.