3

I am currently running a dual boot of Windows 10 Home 64-bit and Xubuntu 15.04 64-bit on my machine. I have Windows 10 on an SSD, Xubuntu on another SSD and an HDD for storage formatted as NTFS (this is used to store music, games, documents, pictures etc.). The GRUB2 boot-loader is also on the SSD with Xubuntu. Previously I used this exact set-up with Windows 7 instead of 10 and there were no issues with booting into my desired OS via GRUB2, as well as being able to mount the NTFS storage drive in Linux.

Here is the problem I am experiencing now:

After about 10 or so boots into Linux, I turn on my computer and the boot order has changed and it wants to boot straight to Windows 10. After changing the boot order back, my NTFS drive will not mount due to the error described, and resolved by Can't Mount NTFS drive “The disk contains an unclean file system”.

(I can use the fix provided in the link, but this is a major annoyance as there are dependencies between my Linux OS and the NTFS drive.)

My boot device order is USB, Hard-disk, CD-ROM (all non UEFI) followed by others including the UEFI options. For the Hardisk order I want to have Linux, Windows, Storage... but when the boot order gets reset I get Windows, Storage, Linux.

I have a hunch it has something to do with "Secure Boot" and Windows 10, where Windows 10 prevents other bootloaders from functioning. I skipped Windows 8 so I am not familiar with this feature, and after some research I am a bit confused about Secure Boot and how to deal with it.

So my question is: How can I prevent Windows 10 from changing my boot order and messing with the mounting of the NTFS storage drive?

Some other pertinent information:

System Specs

i7-2600k

16GB DDR3

MSI Z77A-G45 (I updated the bios to the 2013-09-29 version)

Kingston 128GB SSD - Linux

Adata 128GB SSD - Windows 10

WD 2TB Black - Storage

BIOS INFO After the update in the advanced settings menu there is a Windows 8 features menu. If I enable Windows 8 features I can then choose to enable or disable secure boot, but when enabling Windows 8 features I am forced to boot with UEFI devices and my computer cannot boot. So I have the Windows 8 features toggle set to disabled right now.

  • I think some of your issues may be related to Windows "fast boot". You should try disabling it and see if it fixes the issues: askubuntu.com/questions/452071/… – chue x Aug 6 '15 at 23:52
  • That is an option in the BIOS I CAN change. I will give it a try. – jasper Aug 7 '15 at 2:56
  • Sorry for the confusion, but Windows fast boot is not the same as a bios fast boot. You should be able to change it in Windows control panel under one of the power setting pages. – chue x Aug 7 '15 at 3:23
  • OK, noted. I just turned it off. I have gone between OS's a couple times so far and everything seems all right. I will come back and answer the question after a few days (if things seem to be working properly) as that is how long it took before the problem became apparent. – jasper Aug 7 '15 at 4:25
1

The reason for my problems was that Windows Fast Boot was turned ON. I turned it off by going to Control Panel->Hardware and Sound->Power Options->System Settings and deselecting Turn on fast startup under Shutdown Settings. Grub has been loading flawlessly for the past five days and their have been no conflicts between Windows and Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.