I don't know what caused this, but in Windows 10, this wrong icon is spreading like a virus everywhere!

Some examples:


This icon somehow displays on some desktop icons, task bar icons and in start menu, for no reason. I tried several ways to clear the icon cache, but none of them worked.

This is Windows 10. But this bug has been present in all Windows versions I can remember.

How do I get rid of this misterious bug?

  • 1
    Have you tried to rebuilding the icon cache?
    – Ramhound
    Aug 7, 2015 at 12:56
  • That is the new default icon for images opened with the Photos app. It looks like your icons or thumbnails need to be refreshed. Try some of the solutions here and see if it helps: superuser.com/questions/951955/preview-photos-in-windows-10
    – MC10
    Aug 7, 2015 at 13:06
  • No, using disk cleanup to delete thumbnails didn't help.
    – bytecode77
    Aug 7, 2015 at 13:07
  • Did you try rebuilding as well and/or restarting? It's strange that it shows the correct icons for some and not for others. Perhaps run System File Checker sfc/ scannow in Command Prompt and see if it repairs any files.
    – MC10
    Aug 7, 2015 at 13:31
  • I tried rebuilding & restarting using this batch file: tenforums.com/tutorials/… but still with no success.
    – bytecode77
    Aug 7, 2015 at 13:32

7 Answers 7


I have the same problem as well. Rebuilding icon cache does not work either. It seems that Acrobat DC link is messed up.

Here is how I fixed it. From start menu, right click on Adobe Acrobat DC => Click More => Click Open File Location. In my case, the icon location is at C:\ProgramData\Microsoft\Windows\Start Menu\Programs (lets call this one SartMenu folder)

Select the icon, and press Delete

Fix Approach 1 If you already have a Adobe Acrobat DC link on your desktop with correct icon, you can simply copy this icon over to the StartMenu folder

Fix approach 2

Proceed to open a new Windows Explorer window and browse to C:\Program Files (x86)\Adobe\Acrobat 2015\Acrobat. Create a short cut for Acrobat.exe to the Desktop, and then follow the step in Fix Approach 1

  • Interestingly enough, this visual bug does not seem to be reproducible anymore. Maybe Adobe fixed their software, or it was something else. Who knows...
    – bytecode77
    Oct 3, 2016 at 19:16
  • This is more like a workaround to the problem, rather than fixing the root cause.
    – VCD
    Jul 12, 2018 at 13:02

I believe the underlying reason is the Adobe MSI installer breaks Microsoft's rules for creating a Windows installer package. Under the documentation, we read:

Icon files that are associated with shortcuts must be in the EXE binary format and must be named such that their extension matches the extension of the target.... For example, if a shortcut is to point to a resource having the key file Red.bar, then the icon file must also have the extension .bar.


In the MSI installer for Adobe Reader DC / 2015 / 2017 we see the 'Icon' table entries, all of which have the extension '.ico' by default:

Adobe Acrobat Reader DC Icon table

If you edit the MSI with Orca and do a find/replace to change '.ico' to '.exe' on every relevant table, and then repair / reinstall the MSI, the problem does not reoccur. It would be helpful for Adobe to fix this in the MSI directly for everyone in another release.

  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Apr 15, 2018 at 20:16

After the hints from Minkus (which he is correct from application point of view), I dig further and found out the root cause of the wrong icon is due .ico file associated with other applications which were unable to handle the icon if the content of the .ico file is actually a .exe file, such as Windows 10 Photos app. In other words, when you double click on the .ico file, the application which was launched was unable to handle the icon (due to what Minkus mentioned).

Instead of uninstalling the application which was associated with the .ico file (which should work as well), just do the following:

  1. Find yourself an .ico file, or just create one yourself by renaming a file to one with extension .ico.
  2. Right click on it, then choose Open with > Choose another app.
  3. Choose Paint, optionally check Always use this app to open .ico files, then click OK.

If you choose Always use this app to open .ico files, the icon should back to normal immediately. If you didn't, then you will need to reboot your PC.

This should fix most wrong icons on taskbar, desktop, shortcut, except those in Start Menu search result which I still have no idea how that can be fixed.

  • This really explains the root cause. I had changed my .ico files to use Paint3D as the editor and then my Adobe Reader and TortoiseHG icons were changed to the Paint3D icon when pinned to the taskbar. It was crazy. I changed ico to be edited with paint and everything reverted back so the correct icons are now used for TortoiseHg and Adobe Reader. It's a crazy bug.
    – raddevus
    Jul 2, 2019 at 15:56

Try right-clicking on the taskbar and running Task Manager. In the "Processes", under the "Windows processes" section, you should find "Windows Explorer" nearly at the bottom of the list. Click on it and then click the "Restart" button. This fixed the incorrect icon in the taskbar for me.


Three of the many programs I have pinned to the taskbar, were showing an incorrect image on their taskbar icon. It was the same, plain image, in all three cases. This is what worked for me.

  1. Start the program (if it isn't already running).

  2. Right-click the program's icon in the taskbar, and click "Unpin from taskbar".

  3. After a few moments, the correct image replaces the incorrect image on the icon.

  4. Right-click the program's icon in the taskbar, and click "Pin to taskbar".

  5. Repeat this process for each program, as necessary.

  • 2
    Doing step #4 reverts the icon back to the wrong icon. The issue was not reproducible for some time, however now it is.
    – bytecode77
    Feb 8, 2017 at 16:50
  • In order it for works, you should first delete the icons cache "C:\Users\....\AppData\Local\IconCache.db" and restart. Only then it worked for me
    – Boaz Nahum
    Jun 26 at 7:42

I have the exact same problem with the same applications affected.

I uninstalled the Windows 10 Photos app. This seems impossible from the normal Apps and Features dialog. Even though it does show up there, I can't uninstall from there. I found here that it's possible to uninstall it from PowerShell with the command Get-AppxPackage *photo* | Remove-AppxPackage.

This restored the correct icons immediately, except in the startmenu where a few were fixed and a few are still wrong.

  • This makes no sense, but it worked for me. I even redeployed my computer and had the same issue, meaning whatever the cause is either followed me with my roaming profile, or it's just a common occurence with Adobe Acrobat/Reader DC (both programs had botched icons for me).
    – TomWardrop
    Jun 20, 2019 at 4:30

Related problem - in Win 10, two programs showed the same icon as a 3rd program (Greenfish Icon Pro) in the taskbar when they were started but right-clicking on the taskbar icon showed opened files with the correct program icon beside them. Problem solved by uninstalling GreenFish Icon Pro, deleting IconCache.db, rebooting and re-installing GreenFish Icon Pro. All taskbar icons now correct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .