2

I have a passive network tap that I have put between two hosts. The cabling scheme of the tap looks like this:

enter image description here

The tap is connecting only two pins (one twisted pair) to each of the two network cards that are used for traffic monitoring. I have the problem that one network card (which is built in) works fine under that setup (the link light is on and it receives/monitor traffic), but the other network card, which is a USB network card does not receive anything and the link light is off.

Promiscuous mode is ON on both cards. I get the same results after switching the cables between the network cards. The USB network card can sniff traffic if I connect to a standard host (with all pins connected). The device the USB NIC is connected to is a Raspberry pi, so that's why I have to use a USB NIC as the second NIC.

Is there any way I can make the USB NIC receive traffic if only two pins are connected?

1 Answer 1

0

I figured out that the working adapter defaults to 100mbps, and that the nonworking adapter defaults to 10mbps, and that's probably the reason why the USB adapter does not detect the link state as up.

But I'm not jet able to confirm this because I am not able to change the speed on the USB adapter, but thats probably a different question. I will post it a bit later as separate question. The error I get is:

root@kali:~# ethtool -s eth1 autoneg off speed 100
Cannot set new settings: Operation not supported
  not setting speed
  not setting autoneg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.