3

I upgraded my machine (after a lot of pain) to windows 10. My wireless adapter seems to be working correctly, although the signal in the room is too poor to use the internet via wifi, but the ethernet adapter is not displayed in device manager and I cannot use the ethernet connection.

Current OS: Windows 10 64bit Motherboard: Gigabyte G1.Sniper(1.0) CPU: Intel i7 990x Computer is custom built

I tried using the disk that came with the motherboard, but before even attempting any installation of drivers it says that the OS is not supported. The website for my motherboard does not list any drivers for windows 10 (bigfoot LAN seems to be what I am looking for).

I tried using the windows 7 driver: it gets all the way through installation - the adapter temporarily appears in device manager - but right at the end, when it is "registering product", it says a fatal error has occurred and appears to revert the changes.

The update notification said I was eligible for windows 10. However, I cannot find my motherboard here, and although the gigabyte microsite says "the drivers and BIOS on all current GIGABYTE motherboards are ready and optimized for Windows 10", my motherboard is not displayed on the website.

How can I use the ethernet connection on the computer?

Edit: My network card is Killer 2100. Tried installing windows 8.1 driver from https://www.visiontek.com/download-drivers.html and the same thing happened.

1
  • Tricky one... Is the network adapter showing in the device manager? If so, find the hardware ID to help with the search; also, is there any indication in your event viewer of why the installation not working? Anyhow, BigFoot was acquired by Qualcomm Atheros about four years ago so you might start searching there. Good luck. – DungeonMaster3000 Aug 7 '15 at 15:23
1

If this is a driver problem you can follow the steps

  1. Download driver identifier
  2. Install it and let it search for drivers
  3. It will output a file called drivers so copy it and open it in a computer with internet
  4. There you can see all your devices find the network card and download the latest driver from a manufature(Gigabyte if it's there)
  5. Install the driver in your computer

Hope it helps

0

Had a similar problem. I found that on going to the device manager and checking the network adapter it had been disabled by someone; not by me to my knowledge). I then enabled it and the Ethernet connection appeared and works fine. Hope this helps.

0

This isn't going to be an answer that you may like, but this is most likely what is happening. FYI for anyone not familiar with the term NIC, it means Network Interface Card, or in other words the network adapter.

Answer: Your product does not have a Windows 10 Compatible Driver. I would suggest using any built-in NIC on your motherboard, and/or look at upgrading to a newer NIC with Windows 10 drivers.

Looking at the website you gave, it shows the latest driver for the Killer 2100 NIC is for Windows 8/8.1, and Windows 10 isn't showing up. Also according to Killer Networking (http://www.killernetworking.com/support/driver-downloads) that product is a legacy product that is handled by VisionTek, which doesn't guarantee the NIC will get Windows 10 drivers. You will need to contact VisionTek to check whether they are working on Windows 10 Drivers for the Killer 2100, or have a driver compatible with Windows 10.

Like with every piece of hardware, there has to be a Driver compatible with your version of Windows, and Windows 10 doesn't always work well with Windows 7/8/8.1 drivers. In some cases it doesn't work, doesn't work as expected, or disappears from the Device Manager (not 100% sure if it's uninstalling it or hiding it).

0

Ok, I’m sorry for reviving an old thread ...

HOWEVER!

there are some people who, like to keep old hardware.. and I’m sure that as like I did, when googling this thread comes up but I have a “workaround” to the issue here.

So, here is my way to workaround installing the drivers for the killer network drivers in windows 10.

Download the latest drivers you can find. You may need to setup windows to “show hidden files”

Run the installer, that’s it! Don’t click anything, it will extract the files we need to a temporary file.

Minimise the program install window,

Go to user/appdata/local/temp

Sort files by modified and the newest two folders will be the driver folder and the software folder. This is easily identified when scrolling through the files as one will have killer network manager application executable and the other will contain the .msi file for the drivers.

This is the tip, open the drivers .msi file with 7zip and extract the files into the directory. Now we have the folder for the executable files, open this folder and there you will find the data1 cabinet file, again using 7zip extract this file into the folder!

That’s it! Inside the new data1 folder will be the system drivers you need.

Go to device manager and right click the network adapter and “update driver” select let me choose drivers from my computer. Point the explorer to the new folder you’ve extracted and voila!! Your machine should install your network drivers.

So again, sorry for the ancient thread revival but hopefully it may help someone. Yes, I did join just to send this response.

1
  • 1
    So, I add a useful comment and all someone can do is vote it negatively. Really constructive 👍🏻 – Pengy666 May 21 '20 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.