4

I've just upgraded to Windows 10 from Windows 8.1 on my Microsoft Surface Pro. OneDrive is telling me it cannot use the current location I had configured in Windows 8.1, which was located on my 128GB SD-card.

I've tried the usual suspects with the mklink command-line utility to create a symbolic directory link from C:\Users\xxx\OneDrive to D:\OneDrive like:

mklink /d C:\Users\xxx\OneDrive D:\OneDrive

and

mklink /j C:\Users\xxx\OneDrive D:\OneDrive

and even:

mklink /j C:\Users\xxx\OneDrive2 D:\OneDrive
mklink /d C:\Users\xxx\OneDrive C:\Users\xxx\OneDrive2

Nothing works. When I open OneDrive, it asks me for the location of my OneDrive folder, which I the point to C:\Users\xxx\OneDrive, however, it keeps saying:

Your OneDrive folder can't be created in the location you selected.

I'm now in the middle of creating a .VHDX on the SD-Card, and mounting that in C:\Users\xxx\OneDrive, which I presume will work; however is there a nicer way? Perhaps some registry tweak? Perhaps a big hammer?

6

As of today this is now officially supported. Simply pick the removable drive you want to use.

https://onedrive.uservoice.com/forums/262982-onedrive/suggestions/6449138-allow-onedrive-to-sync-to-removable-media-on-windo

0
0

I managed to use SD card by mounting it to c:\sd using diskmgmt.msc

The dialog to select the folders will still however think that you have as much space as c:, so add the data in parts to fool it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.