I have a strange problem.

If I boot into windows (7) using Bootcamp, then the next time I boot into OSX (Snow Leopard) Airport cannot connect to my wireless network. It can see the network but with a low signal strength (2 bars). Connection fails with a timeout error.

If I boot back into Windows, the wireless works again.

I haven't figured out why, but after a few dozen reboots between windows and OSX, Airport will finally connect to the wireless network and the signal strength is back to full (all bars full).

This is definitely not an environmental issue. The wireless is lost as soon as I boot back into OSX from Windows, and it still works when I boot back into Windows. So there is no interference or anything. I have had solid signal strength for a year or so with no connection problems. This first happened when I booted into Windows 7 after installing it. My iPhone works, as well as the 2 other machines in the house.

I filed a bug report with Apple but I think it's just going to be marked "cannot reproduce" and forgotten. I have also completely trashed all the system network settings and set things up again, to no avail.

I have a Netgear DG834GB. I cannot see any sort of security/firewall messages. I did actually find one single thread on a forum somewhere where somebody else had this exact problem, but I have lost the link. But there was no solution anyway.

So, has anybody got any suggestions?

| improve this question | | | | |
  • Does this only happen after booting Windows? If you are in OSX and it works fine, and you reboot a couple times without going into Windows does it work every time or no? I might have an idea on what is going on but I need this info first. – Marcin Jan 17 '10 at 21:10
  • What machine? What services are you running? – Charles Stewart Jan 18 '10 at 9:50
  • This only happens after I have booted into Windows using Bootcamp. The next time I boot into OSX the problem has appeared. – Mike Weller Jan 19 '10 at 9:34

See this article: Airport in OSX Dropping Wifi Connection from December 23, 2008.

This guy has compiled the list of all the solutions for Airport connectivity that worked for some people (but didn't work for him).

What finally worked for him was to go into the Airport Extreme settings and change it from b/g/n to N-only (on channel 11).

If this doesn't work for you, you might have a look at the above article.
The list of solutions is too long to include here.

| improve this answer | | | | |

If you don't reboot from Windows to Mac OS X, but shut down completely (turn off the computer), does it work when booting OSX afterwards? If so, the problem is likely that Windows is shutting down the wireless card when it exits, and OSX can't bring it back to life.

I'm not sure what to do about that, other than reporting as a bug to both companies involved, but a power cycle at each reboot should be a workaround.

| improve this answer | | | | |
  • No, shutting down does not work. I have also tried resetting the PRAM and draining the power by holding down the power button while not plugged in to the mains. – Mike Weller Jan 19 '10 at 9:31

In this thread Boot Camp: Networking, a reader says:

One thing that may be affecting the behavior of AirPort throughput under WinXP vs. OSX is AppleTalk. AppleTalk is horribly inefficient, so if it's enabled under OSX, you will most likely see worse performance w/ AirPort than under WinXP, since WinXP doesn't support AppleTalk.

Although I'm not a Mac user, it may be that disabling AppleTalk might improve AirPort throughput.

| improve this answer | | | | |
  • ixnay, this has nothing to do with it. appletalk is seldom used these days, even by Apple itself. the comment you link to is completely misguided: enabling a setting (eg: AppleTalk) in Mac OS has no effect on your Windows install – username Jan 18 '10 at 10:02
  • @username: The wireless problem is rather on the OSX side, so we're talking OSX and not Windows. Even if AppleTalk is unused, I wonder if it's still enabled on the poster's computer. – harrymc Jan 18 '10 at 10:16
  • google the DG834. it is finicky. the post you link to should be ignored. for starters, the person who posted it does not understand that 99.999% of Mac OS settings do not even make it to the BootCamp partition. I think the poster may be thinking of Bonjour? AppleTalk has been almost entirely phased out of the OS (only ever used to talk to printers). I've never ever heard anyone suggest disabling it as an approach to troubleshooting wifi connectivity before. cheers – username Jan 18 '10 at 12:16
  • I can find no references to AppleTalk on my system and according to wikipedia it is no longer supported in OSX 10.6. – Mike Weller Jan 19 '10 at 9:32

Change security on the router from WEP to WPA. Both Windows and Mac OS will work. This advice only applies to your Netgear DG834 - doesn't usually make a difference on other routers.

You can change security on the router by logging on to its web config page. Check the NetGear manual for details, but it's usually

| improve this answer | | | | |
  • If it still doesn't work, I would check for router firmware updates... at that point I would test with an alternate wifi router. – username Jan 18 '10 at 13:24

Another thing that might be going on: have you changed your SSID, or is it still "NETGEAR"? Because if someone else in the neighborhood is using the same network name (there's two with that name on my block), your Mac might be attempting to connect to the wrong network when you reboot.

| improve this answer | | | | |
  • This isn't the problem. – Mike Weller Jan 22 '10 at 15:20

Well, upgrading the firmware seemed to do the trick. It was an obvious thing to try but I didn't get round to it until just recently. The exact cause is still unknown.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.