20

Upon cold boot up or even a restart, the num lock is always disabled in Windows 10. Is there a fix for this?

1

4 Answers 4

8

I found a solution which worked beautifully on Windows 10:

  1. I first tried to find a Num Lock option in the BIOS, but found none. (ASUS G53SW)
  2. I then tried to reboot from the login screen with Num Lock on to see if the system would remember it, but it didn't work.
  3. I then tried changing values in the registry:

    HKEY_USERS\.DEFAULT\Control Panel\Keyboard --> "InitialKeyboardIndicators"
    
    • Changed from default value `"214783648" to "214783650", which didn't work.
    • Changed to "80000002", which didn't work.
    • Changed to "2"`, which didn't work.

    I reverted it to "214783650", then for some strange reason I thought that maybe Windows tries to activate it, but has trouble communicating with the keyboard controller.

  4. I went on my manufacturer's support site, downloaded the Intel chipset driver update utility, and the problem was solved.
2
  • 1
    So issue is with chipset? If I have AMD and same issue, then should I try it or stick with disabled fast boot option (because it also solves the problem)?
    – Eugene
    Nov 7, 2015 at 12:09
  • "80000002" worked for me. As well as '.DEFAULT' there were a number of other "S Users" e.g. S-1-2-3 that I applied it to as well. Hopefully this helps somebody.
    – robert
    Apr 5, 2017 at 12:04
3

There is a partial solution that involves setting InitialKeyboardIndicators to 2 in [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]. However this only works after complete reboot, not after sleep, lock, hibernate, or fast startup. In that case Numlock ⇩ always turns off regardless of it's previous state.

Most laptops today use a fast startup, which basically hibernate your PC instead of shutting it down. You can disable this feature in your power settings. Then the numlock should be on after startup.

Disabling fast startup:

enter image description here

Please note that disabling fast startup may significantly increase your boot times on a standard HDD.

It will still turn numlock off when PC goes to sleep or lock sate or when you hibernate it manually tough. I'm sure you can find this issue in your localized Windows feedback app, support it so MS may fix it one day.

2
  • For me changing the value to "2" worked on Windows 10, with "Fast boot" enabled Mar 19, 2016 at 17:09
  • This is part of the solution. I would have added my own, but my association bonus doesn't count. So I took it from How to Enable Num Lock Automatically When Your Computer Boots on How-To Geek. It states also to change the InitialKeyboardIndicators in several other directories.
    – TT.
    Jan 20, 2018 at 11:06
1

Unfortunately there is no fix. Microsoft decide to let you log in by PIN, but the old registry hacks no longer work, so Num Lock is always disabled on boot.

2
  • PIN....??......you mean microsoft account?
    – Moab
    Aug 8, 2015 at 2:00
  • 4
    @Moab PIN, as in... Since Windows 8 you can set a PIN to log in with
    – td512
    Aug 8, 2015 at 2:01
-2

1.Go to the following Registry key: HKEY_USERS.DEFAULT\Control Panel\Keyboard 2.Set the value "InitialKeyboardIndicators" to 2147483650. 3. Restart (This will turn on NumLock on the logon screen starting from the next boot).

1
  • 2
    Have you tested this to make sure it works? The value of the key is odd, in addition, the other answer says this doesn't work. This also seems to be word for word from winaero.com
    – Ramhound
    Aug 10, 2015 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .