40

I recently setup a new computer for my parents with windows 10 home. I made two local accounts for them - no microsoft accounts. I also would like to keep them without a password. Problem is now that windows automatically signs in with the last used account. No lock/login screen.

I tried a number of answers from similar questions here but none worked. Since it's a home version there are no group policies and the method using task scheduler does not work because accounts with no password are not allowed to create such tasks.

Are there other options to force windows to show a user list on startup without setting passwords for the accounts?

43

The following link describes how to change this behaviour in Windows 8 using a registry setting and some permissions on that registry setting. It also works with Windows 10.

http://www.eightforums.com/user-accounts-family-safety/10004-help-multiple-users-login-screen.html


First launch the registry editor: Press WIN + R, type regedit and click "OK".

Navigate to the following path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch

Change value of the key Enabled from 0 to 1

There's one more problem to solve: The user SYSTEM automatically changes the value to 0. So we will disallow the user SYSTEM to change it.

  • Right mouse click at registry key UserSwitch -> Permissions
  • Click on Advanced and then on the Disable inheritance-button; if your are prompted with two options now, choose the first one (Convert inherited permissions into explicit ones for this object)
  • At the top of the dialog, change the owner from SYSTEM to the group Administrators (if your Windows is not in English, the name might differ a bit, e.g. in German it would be "Administratoren")
  • Select the group Administrators entry -> Allow -> full control
  • Double click the entry for SYSTEM, select type Deny and click on Show advanced permissions. Here Clear all -> only check Set value
| improve this answer | |
  • I think I've messed up something. After I click on "Disable inheritance", a dialogbox pops up saying something about implicit inheritance or disable all inheritances, I guess. Which one I should've clicked on? – Gui Imamura Dec 19 '15 at 7:23
  • @GuiImamura: I chose the first one (Convert inherited permissions into explicit ones for this object) and it worked for me... – mozzbozz Dec 23 '15 at 10:58
  • 1
    Ugh. This solution ended up leading to the problem described here briteccomputers.co.uk/forum/… in which UAC prompts errored with "Extended Attributes are Inconsistent". – G-Wiz Jul 3 '16 at 4:26
  • 5
    It seems that after the Fall Update, this doesn't work anymore, and Windows logs me in automatically again. Anyone else seeing this? – Berend Oct 30 '17 at 16:02
  • 2
    Too bad this is not a permanent solution. – pacoverflow Aug 12 '19 at 19:00
5

A solution posted by Larry Jacobson on the Microsoft Community Q & A that I've confirmed works is to disable the automatic use of sign-in info for every single account on the system. You access that option in the Settings app under Accounts > Sign-in options, in the Privacy section.

Make sure to disable the option for every single account on the system, not just the account that gets signed in automatically or all accounts without a password.

Screenshot showing the disabled sign-in option in the Windows 10 Settings app

| improve this answer | |
  • Just tested on a Windows 10 1909 computer and this does not work. – Thomas Feb 6 at 17:04
2

Open netplwiz by pressing Win+R, and typing netplwiz. It will give you advanced user settings. Find a check mark that says

Users must enter a username and a password to use this computer

and set it to true (check it).

| improve this answer | |
  • 14
    This does not work when there is no password fora user. – Kangkan Oct 18 '15 at 7:04
  • Yes; Yes of course it does. – Ramhound Jul 26 '17 at 23:29
  • 10
    @Ramhound: No, it really doesn't. Try it yourself. Create an account with blank password. Log in to account. Initiate reboot. Watch account log in automatically. – ziggurism Oct 7 '17 at 16:53
1

Windows 10 64-bit

How to disable auto logon using the Windows registry.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"AutoAdminLogon"="0"
"DefaultUserName"=""
"DefaultPassword"=""
| improve this answer | |
0

If last user does not have a password and after reboot Windows 10 Auto Logon from last user without password null. You can stop autologon by putting a random password and reset it after a restart. Create startup/shutdown script (Computer GPO Local) : * Startup Script : Net user [User] "" * Shutdown Script : Net user [User] RandomPassword

it works with windows 10 1909.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.