I am trying to get two way serial communications going between a Windows XP system and a Linux system (RHEL 5). I have

/sbin/agetty -L 9600 ttyS0

in /etc/inittab.

I am using a generic USB to serial adaptor on Windows (Unitek) and a null modem cable.

I have putty configured for 9600 baud, 8 bits, no parity, one stop bit, no flow control.

I get the login prompt from agetty in the putty window but input does not work; I see weird characters in the putty screen. I can echo output into the device from windows and see it, but

cat < /dev/ttyS0

just prints out weird characters from what I type.

Any and all suggestions will be welcome.



It turned out to be a cable issue. I was using a null-modem cable and a straight-through cable was needed. I did some testing using two USB-to-serial converters on the Linux box so that I wouldn't have windows in the picture and was able to isolate it to the serial cable.

Thanks for your responses.

|improve this answer|||||

Are you sure the hardware is working ok? I would suggest opening a serial terminal program on each side and send text each way (hyperterminal on windows, minicom on linux).

|improve this answer|||||

Not saying this is your case, but in the past I used the same cable to connect a laptop to some working machines. Didn't work ... whatever we did, it didn't work. The cable was ok though.
Then we tried a different brand of cable (everything else, the same) ... worked!

Never found out what was wrong ... but heard from other people having the same problem. This is not very helpful, just saying ...

|improve this answer|||||
  • "... try another cable." yup, not the greatest explanation of why it happens, but sometimes it works. – quack quixote Jan 13 '10 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy