So I've done a good bit of research on this issue and it appears that some PCs that have Daemon Tools or Alcohol (disk emulators) tend to have problems on booting when your computer loads SPTD.sys. A majority of the problems are reported by users on Media Center Edition (possibly some conflict with a driver that ships on the OS). The issue is that I can't boot up (including in safe mode) without loading that driver. If I go with the prompted safe mode, after loading AGP440.sys it prompts me to hit enter to load SPTD.sys, but whether I hit enter, escape, or wait, it still bluescreens and restarts.
Since I can't boot up in safe mode, I can't even get to a place where I can just uninstall the thing. I'm guessing my best bet is to dig out my xp CD and boot into the recovery console so that I can axe it. I'm probably going to eventually just start over with Ubuntu on this thing since it's really a productivity laptop, but at this point I'm in recovery mode because I'd like to get everything vital off of it before making any long-term decisions, so please don't give me grief about having a media center PC... I'm well aware of its problems.

Question : Is there a way to remove this driver without booting from a recovery disc? If so, what is the process to do this?

  • When you go into safe mode, and abort the loading of the SPTD.sys, and it still bluescreens, what does the Blue screen say? (I..E which Stop error is it)? – Ƭᴇcʜιᴇ007 Jan 13 '10 at 16:16
  • I can't see it, it lasts for about 2 split seconds before the computer reboots – NateDSaint Jan 13 '10 at 17:30
  • Ok next time you reboot hit F8 to bring up the boot menu (where you would pick Safe Mode) and pick "Disable Automatic Restart on System Failure". Next time it blue-screens it should stay up so you can read it (until you manually reboot). – Ƭᴇcʜιᴇ007 Jan 13 '10 at 18:22
  • Thanks, @techie007. It's saying this : STOP: 0x00000024 (0x00190203, 0x8A197AC0, 0xC0000102, 0x00000000) – NateDSaint Jan 13 '10 at 18:40

You might try to boot in Safe mode and press ESC key when you see on bottom line of display:
Press ESC to cancel loading SPTD.sys. This will abort loading of the SPTD layer.

If not, Offline NT Password and Registry editor is said to contain registry-editing tools.
I never tried this tool, but you need to delete the following registry key :

If not, and you can boot into the recovery console, enter the command:

disable sptd

(You can also in that case delete the driver itself.)

  • repeatedly spamming the escape key during the entire boot process does not keep this from happening. It looks like I'll have to try one of the other methods. I'll come back and see if either of these work tonight when I'm at home, and if so will accept this answer. Thanks for your quick response! – NateDSaint Jan 13 '10 at 16:14
  • Well, for whatever reason disable sptd returned a series of errors, stating that the service could not be found. So I ran a CHKDSK (which took about 5 and a half hours), and that at least got it to the point I could boot in safe mode. I then deleted Daemon tools and removed SPTD from the registry, and now it appears to work. Thanks so much for your help! – NateDSaint Jan 14 '10 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.