I have a computer running windows 8.1.

I had previously created a homegroup on my computer, and updated to Windows 10. I reverted back to Windows 8.1, and was no longer a member of the homegroup I had previously created.

When I try joining that homegroup, it says 'This homegroup no longer exists'.

No other PC's on the network see this homegroup. When I open 'Control Panel/HomeGroup' I see this:

homegroup exists

Then, when I click Join - I get this series:

enter image description here enter image description here enter image description here enter image description here

I enter the password, and then...

enter image description here

I have tried removing all the PeerNetworking files, restarting the HomeGroup and PeerNetworking services, rebooting, etc. Nothing seems to work.


I also tried renaming my computers Computer Name in the system settings, that did not work either.


Does anyone have ANY other suggestion other than what I have found on the net so far?


Source: www.cnet.com/forums/discussions/win-10-homegroup-issues/

  1. Go to C:\ProgramData\Microsoft\Crypto\RSA\
  2. Rename MachineKeys folder to MachineKeys-OLD
  3. Create a new folder C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys
  4. Right click the MachineKeys folder and select Properties and click Security tab
  5. Highlight Everyone, click Edit then set Full Control permissions to Everyone
  6. Restart

This worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.