1

The title may seem vague, but I've tried so many things that I'm not even sure what to label the issue as.

I got a new PC so stored my old PC parts away. I then got a new case so thought I'd put together my old PC again. The problem is I cant get it to boot into any OS.

The parts are all exactly the same as previously, and the SSD in the PC is the same as it had before, not tampered with. The drive had Ubuntu on it. When booting, I get to the grub menu and if I select Ubuntu it just goes to a black screen and nothing seems to happen.

So I downloaded the latest Ubuntu, put it on a USB thumb drive and tried to install from that. Although it gets to the Ubuntu setup menu, when I press "try Ubuntu without install" or "install Ubuntu" it goes to a screen and the cursor just blinks constantly. My old graphics card is a Radeon 5770; which is in the machine. I have also tried my new GTX 970 card and got the same issue.

I also downloaded an arch Linux disk, and tried to install with that- I got the same issue that I got with Ubuntu. So I tried changing the HDD and still got the same issue.

I then tried an old Ubuntu liveCD I had (which has worked previously on this PC); assuming it could be the ISO I downloaded or the USB drive. I still got the same issue.

I also tried a Windows 8 and Wndows 10 install on both DVD and on USB. They both froze on the splash screen with the spinner circle spinning (the circle stops spinning when it freezes and it stays like that forever).

I have done a memory test on the Linux live disk, and everything was fine there.

I'm really at a loss as to what the issue can be. Any ideas on what I can try to diagnose and fix this? I have tried some kernel options as mentioned by other posts, nomodeset, radeon.modeset=0, etc. They all cause other issues, or have the same issue with the blinking cursor or blank screen.

I would assume that if it was a kernel or Linux driver issue, then windows would work fine.

  • Wild shot in the dark here, but perhaps there's a graphics (Xorg etc) issue which is causing fallback to onboard graphics? Can you try without any graphics cards? – bertieb Aug 8 '15 at 18:22
  • I dont actually have any onboard graphics – David Esteves Aug 8 '15 at 18:23
  • 1
    Well, that at least eliminates (auto-switching to onboard) that as an issue. Can you remove parts to get the system into a minimum working state- eg one stick of RAM, all internal drives (perhaps leaving optical drive) disconnects, BIOS factory defaults (ie no 'secure boot' etc) and see if you can load up a liveCD / liveUSB that way? – bertieb Aug 8 '15 at 18:29
  • hah after removing all but 1 stick of ram it is now working. Will slowly try put in additional pieces and see if the issue returns to make sure it is ram related. I also unplugged case fans and the bluray drive, so guess it could be that, just seemed less likely. I did also reset the bios settings before removing everything, and it had the same issue, so I assume that did nothing. Thanks sooo much for your help! – David Esteves Aug 8 '15 at 18:40
  • My pleasure; glad it is working- troubleshooting previously-working hardware can be a pain. It may be worth writing what you end up doing as an answer and self-accepting, so that other people with similar problems can benefit from your experience :-) – bertieb Aug 8 '15 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.