21

In Windows 8, when Alt+Tab, the desktop would appear as an option to switch to at the end of the list of open programs (thus Alt-Shift-Tab helpfully took you right to the desktop).

In Windows 10 that desktop option is gone. Is there any way to get it back?

I know about Windows+D but Alt+Tab is just more convenient in my opinion. And switching to the old old alt-tab also has no desktop and is uglier.

  • I have exactly the same issue. – Devid Aug 10 '15 at 13:03
  • That's really odd. I still have it on my list. imgur.com/P3W8KIc – Nathaniel Saxe Aug 17 '15 at 9:45
  • same problem, kind off frustrating, i now have to alt tab then continue holding and click on the desktop. not optimal – Choco Smith Aug 17 '15 at 21:41
11

I agree that the Alt + Tab was a convenient way to get to the desktop, and it's hard to break old habits. Of course the Win + D is faster, and I think that may be my new Go to instead of paging through with Alt + Tab.

But another alternative is to add the Desktop to the Taskbar. Clicking on it gives you a list of everything in the Desktop plus some things that disappeared from Windows XP.

To get Desktop in the Taskbar, right click the Task bar and select Toolbars → then click Desktop to add it to the Task bar.

I hope some feel this is a reasonable alternative.

4

After being very frustrated with this problem myself I came up with a work-around using AutoHotkey. Here is the script:

#SingleInstance force
Loop
{
    WinWaitActive, Desktop.txt
    {
            Send, !{Tab}
        WinWaitNotActive, Desktop.txt
        {
            Send, #d
        }
    }
}

To use it create a text file named "Desktop.txt" and leave it open. When you alt-tab to that file the script will quickly alt-tab back to your original active application and then use Win+D to show the desktop. By doing this it effectively behaves the same as alt-tabbing to desktop did in prior Windows versions, even keeping the desktop shortcut in the expected order in the alt-tab menu. I put both the Ahk script and the Desktop.txt file in my startup folder so they start automatically when I turn on my computer.

1

Have you checked that it's not on tablet mode? Check with the bottom left corner and click the speech bubble and turn off tablet mode if it is on. This is how I fixed mine :)

1

While upgrading keeps the option available it does not show the desktop as an icon, and it often bugs back to the current application if there is only one.

If you have two or more it won't go back to the desktop.

0

I noticed that if you did a complete wipe and installed Windows 10 then the Alt + Tab option was gone. However, doing the upgrade from 8/8.1 to Windows 10 kept the Alt + Tab option enabled. I don't know why it happens like that, but it does, at least it does from my experience. If you can, install Windows 8/8.1 and upgrade to Windows 10 and you should have it again! I hope this helps.

Source: My friend did a complete install of Windows 10 while I just did the upgrade. His was gone, but mine is still there. I tested the same thing on my laptop after installing new hardware, and it performs the same as my desktop.

  • I did an upgrade from 8.1 and it's gone, so that can't be it, thanks though – bhalperin Oct 24 '15 at 15:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.