16

I'm not expert on this argument, so I don't know which information could be useful. On Windows 8, I succeded in using Cisco VPN Client.

Now I've installed Windows 10, but when I launch the installer, there's a windows popup which says that Cisco VPN Client is not compatible with this version of windows.

I've a .pcf file with all the information of the VPN, is there any way I can use it on Windows 10?

I've read this discussion, but I think that my situation is different: No network connection after upgrading to Windows 10. Cannot rollback to 8.1

5

I just recently used this shorter article, below. But of course, before that I actually upgraded to Windows 10.

Pre-Req, Upgrading to Win 10

  • I had to uninstall Cisco VPN before upgrading to Windows 10, or else I'd have no networking ability.
  • If you're in Win 10 after upgrade and didn't uninstall Cisco first, you likely have no networking ability. Just Revert to Win 7, and then upgrade to Win 10 again.

  • Then, after clean Win 10 upgrade, I was able to use the below steps

General Steps:

  1. Install Sonic Wall Global VPN (for required items)

  2. Install Cisco VPN via .MSI file (I used a copy we already had, 64 bit 5.0.7 for Win 8) (Also, if you run the .exe you'll see an error message that doesn't get thrown if you install via the .msi)

  3. Fix Registry if needed (Remove the crap off the beginning of the Display Name for key HKEY Local Machine\SYSTEM\CurrentControlSet\Services\CVirtA , which in my case became "Cisco Systems VPN Adapter for 64-bit Windows".)

Apparently, some people won't need to fix the registry, but I was getting a 442 error after entering credentials, and fixing the registry did the trick. Similar people are saying similar things about other error messages such as 443.

http://itthatshouldjustwork.blogspot.com/2015/07/cisco-64-bit-vpn-client-on-windows-10.html

UPDATE: This may only work on very early version of Windows 10, and may stop working with later updates. Moving to Cisco Any Connect or other software is highly encouraged. Also, as Bers points out, Cisco VPN Client is no longer supported. So, we've likely now gone far past the point where making this work temporarily was still an idea.

  • You can open the exe using your favorite zip manager (winzip/7-zip/etc.) and extract the vpnclient_setup.msi. Another way that probably works: rename the .exe to .zip and then simply extract files. – Jannes Oct 6 '15 at 12:22
  • Steps above only works if you have not upgraded Windows 10 to Build 10586.3 (Version 1511). If you have upgraded, your WIFI may stop working. Beware! – bratan Nov 19 '15 at 15:41
  • Of course, Cisco VPN isn't officially supported on Windows 10, and many will soon be headed to newer software. The steps above are just a last ditch effort that some have used, and which has worked for me. A more robust/permanent solution is to move to newer/other software. – Greg Nov 19 '15 at 19:19
  • 1
    Seconding @Greg's comment. Yet more importantly, Cisco VPN Client is not officially supported any more on ANY OS. This means no one should it, anywhere, if they have any interest in secure VPN connections. Maybe that should become part of the answer. Cisco VPN EOL announcement here: cisco.com/c/en/us/products/collateral/security/vpn-client/… – bers Jun 18 '16 at 13:22
3

Use Shrewsoft (https://www.shrew.net/download/vpn). It works very well in Windows 10 (including the newest 1607 version). No real issues and it imports in PCF files from Cisco VPN. The only problem you may have is that UWP apps (Metro apps) won't see a network connection while you're connected but Win32 apps have no problem.

  • 1
    Looks like Shrew vpn is dead? Last updated 2013? – pppeater Feb 7 '17 at 17:42
  • 1
    It doesn't matter. It still works great... even under Windows 10 – Lauren Glenn Feb 8 '17 at 20:32
  • When using shrewsoft on windows 10, one limitation seems to be windows universal apps can't connect to the internet. This includes apps like the store, weather, and edge but excludes regular applications like chrome, internet explorer and others. – Jon Aug 10 '17 at 14:09
  • Has anyone got shrewsoft vpn to work windows 10 1709 ? I tried bu it just fails to install with assorted errors including one with a message 'catastrophic error'. – Robin Luiten Dec 9 '17 at 4:54
  • I actually just installed mine that was installed before I upgraded to 1709 and it failed on the first attempt. When I ran the installed after changing compatibility mode to Windows 8 for the installer, it actually completed the installation and appears to have installed. I would try with that first and see if that works for you. – Lauren Glenn Dec 11 '17 at 23:18
1

If you execute the .msi file rather than the .exe it will not peform the version check.

There are also a few other steps that you need to perform to get the client to work on Windows 10 however, so I suggest you follow the steps on this site: http://www.gleescape.com/posts/2917.

Not the answer you're looking for? Browse other questions tagged or ask your own question.