26

Just upgraded my laptop to Windows 10. Everything seemed fine until I tried to connect to my Win7 desktop. Manually typing the name doesn't work (gives me Unspecified Error (0x80004005)), and when I open the Network section in Windows Explorer it is not listed there. What is listed is two of the other computers on the network, neither of which it will let me connect to (same Unspecified Error). All my computers (including the desktop) are functioning and on the network. They can all see each other, and if I turn on a share from my Win10 laptop then it can be connected to by the desktop. But for some reason, the Win10 machine can see only a few of the machines on the network and cannot connect to any of them, seen or unseen.

I thought at first it was the firewall, but no settings helped and even disabling it did nothing. I have made sure that all relevant computers have discovery turned on but that didn't change anything either. I can ping my desktop, both by IP and by name, but even after pinging I can't browse the drives or even see most of the PCs. By the way, this is impacting being able to connect to explicitly shared drives and to the implicit administrative shares (C$, etc.).


UPDATE:

I realized that since I could ping the desktop that I could try connecting via IP address. That worked, and mysteriously fixed the problem of connecting by name. The Win10 laptop still won't "see" most of the network devices, but it now seems to be able to at least connect to them by name. No idea what's going on with it. I would still hope someone can weigh in with a proper fix for the network discovery (or whatever it is that's broken).

  • Did you enable printer and file sharing on the W10 PC? It is disabled by default. – Moab Aug 9 '15 at 21:04
  • 2
    I had a similar problem... I could, for about 12 hours, connect from my W10 PC to my W7 PC. But then W10 PC offered to categorize my network connection, and from that moment forward I could not connect. Have not been able to restore yet, very irritating. I'm watching this thread :) My error message was "network path not found" (even though Network displays the device) – Patrick Moore Aug 20 '15 at 15:50
  • Well, I just found a solution to my problem, maybe it will help you: I turned Firewall OFF on the PC with shared folders; I added port exceptions (TCP 5357-5358 and UDP 3702,5355) to the PC trying to reach the shared folders. – Patrick Moore Aug 20 '15 at 16:04
  • Printer and file sharing has been enabled since before I posted. As far as I can tell it is enabled on the Win7 desktop as well, for all the good it seems to do... – techturtle Aug 20 '15 at 16:06
  • 2
    @JoaoLeme The 3rd sentence in the question specifically states that manually typing the name doesn't work (I was using the ` \\ `). All my machines are Win10 now, and the problem has largely gone away, but it still doesn't work as well as it did in Win7. – techturtle Mar 1 '18 at 13:58
8

I solved this by adding the Windows feature Samba Support.

The story is: I upgraded 2 PCs to Windows 10, one from Win 7 and the other from Win 8.1. The 8.1 PC could not see a Win XP PC and a Linux Raspberry Pi in "Network". Typing in either the machine name (\MACHINENAME) or the local IP address did not work. The other upgraded PC could, however, see everything. By comparing all the settings I could find, side by side, I eventually found (after many hours) that the Win 7 machine had Samba support whereas the Win 8 PC did not.

To install Samba support in Windows 10, do as follows:

  1. Open Control Panel (by clicking on the Start button and typing in Control Panel, then click the App).

  2. I use Classic View, in which case click on "Programs ansd Settings". If you use the standard view, I'm afraid you need to find it yourself. Fairly easy.

  3. In the left panel, click on "Turn Windows features on or off".

  4. If the Security dialog box appears asking for your OK, give it the OK.

  5. The "Windows Features" dialog box appears.

  6. Scroll down to "SMB 1.0/CIFS File Sharing Support" and tick the box. This installs the Samba support.

  7. Reboot once it finishes and you should be able to see your PCs and folders on the network. (Fingers crossed).

  • I'll have to look into that when I get home. The Win10 PC with the problem was upgraded from 8.1, so that could very well be the issue, though I don't recall ever using or installing a Samba service on my other PCs. My previous fix of connecting once via IP address regressed to not working again at one point, though reconnecting via IP again turned it back on. – techturtle Sep 14 '15 at 19:26
  • 26
    Not a fix for my computer, as it turns out. Mine already had the SMB 1.0/CIFS File Sharing Support installed. – techturtle Sep 16 '15 at 20:48
  • @techturtle you are right, did u solve the issue? – Hernán Eche Jul 17 '18 at 14:34
  • Windows own support led me to: support.microsoft.com/en-us/help/4034314/… However, the link didn't help. However, this answer resolved my issue! – Arthur Weborg Nov 1 '18 at 17:57

protected by Community Nov 4 '15 at 20:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.