4

How to disable automatic driver installation in Windows 10?

I have this Broadcom 802.11n Network Adapter (MacBook Pro 2011 w/ Boot Camp) whose driver I need to roll back to an earlier version for things to work properly, however Windows keeps reinstalling the newer version.

I tried the method outlined at http://windowsinstructed.com/disable-automatic-device-driver-download-in-windows-10/ to no avail:

  1. Open File Explorer and go to This PC.
  2. Then click on System Properties
  3. Under the Computer name, domain, and workgroup settings group, click on Change settings.
  4. Click on the Hardware tab.
  5. Under the the Device Installation Settings group, click on Device Installation Settings
  6. Now click on No, Let me choose what to do, then select Never Install Drivers from Windows Update.
  7. Click on Save Settings, a system reboot is then necessary for the changes to take effect.
1

Here are the steps to fully delete the driver software allowing you to cleanly install the drivers you want:

  1. Right-click the Windows Icon on the Taskbar
  2. Click Control Panel
  3. Open Device Manager
  4. Expand Network Adapters by clicking on the little arrow to the left
  5. Right-click on the Device for which you want to uninstall the drivers
  6. Click Uninstall
  7. On the new window be sure to select the option Delete the driver software for this device
  8. Click OK and allow the device to be uninstalled
  9. Restart the computer

This paired with disabling the automatic install from Windows Update will make it so Windows will not reinstall the device with their own drivers anymore.

All you have to do now is install the device with the drivers you want.

  • I tried and did not work, Windows 10 install the driver nonetheless – Allan Veloso Sep 12 '18 at 3:36
  • I discovered why Windows was reinstalling my driver. My driver was the Connexant audio. When I uninstalled it Windows asked me to restart the PC and so I did. Then windows restarted and noticing that the audio was not working first it used the standard driver (what I want) then update it to the Connexant. The solution was to uninstall but do not restart immediately, go back to the device manager and reactivate it, making windows use the standard driver. Then I could restart the PC and windows did not tried to install again Connexant. – Allan Veloso Sep 12 '18 at 3:55
1

Open Windows Services from Control Panel>Administrative Tools

Once open find "Device Setup Manager" in the list and double click it, then change startup type to "Disabled"

This will stop automatic driver installation for all hardware.

enter image description here

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.