1

I have a hard drive (Toshiba MK6459GSXP) which was part of an old laptop, now defunct. When I bought a new laptop, I decided to salvage the hard drive and re-use it as an external. I bought a USB3 enclosure, plugged it in, and it worked… sort of.

From the beginning, the drive was a bit unreliable, but I successfully transferred a few hundred gigabytes worth of data to it. However, it has rapidly degenerated to the point where I can no longer write anything of any significant size to it without experiencing problems.

I suspect that the hard drive is getting slightly less power than it needs at maximum usage, but I'm not sure if the symptoms I see are consistent with this explanation. Here's some information on my hardware setup; for context, I'm doing all this on a linux system.

  • The enclosure is a USB 3 enclosure with one cable and no alternate power source.
  • My ports are indeed USB 3 (USB 3.0 to be precise, I believe).
  • The sticker on the hard drive says it requires DC+5V, 1.0A.
  • Benchmarks for the hard drive say it requires 4.5W at maximum (spin-up).

These numbers seem to put it right on the boundary of what USB 3 can supply, which is why I suspect it's a power issue. Here are the symptoms I see when I try to write to it:

  • Though it originally worked semi-reliably, it only did so from one of my usb ports, and all others experienced the same problems that I now see in all ports.
  • Upon plugging it in, it is not always detected (i.e. it doesn't show up in /dev). Unplugging it and replugging it usually results in it being detected.
  • After successful mount and trying to write, it tries valiantly for a while, but then fails with (as dmesg reports) a Buffer I/O error, some EXT4-fs I/O errors, and a line stating ‘Result: hostbyte=DID_NOT_CONNECT driverbyte=DRIVER_OK’. The disc is then remounted read-only and the write fails.
  • I tried to run the SMART checks (using smartctl) on the disc, but it doesn't give any useful information. The number of fatal errors remains at zero, and it abandons the tests after some amount of time because it loses connection to the disc.
  • There are multiple partitions on the drive, and the above happens with each of them.

Are these symptoms consistent with power supply problems to the hard drive? If not, are there any ideas where the problem might lie?

1

Power supply problems are indeed what I would be looking for, here are a few data points:

  • Many Laptops with "USB 3" ports actually satisfy just the data portion of USB 3, but not the power requirements
  • USB 3 drive enclosures need some power for their chippery, so the total power consumption might be well above that of the drive alone
  • USB is not good at recovering a lost connection, so if the connection to the drive is lost during spin-up or (more often) initial seek, it will not become usable again when power has leveled out

You can verify if this is a power issue by running the drive from a powered USB hub. My experience is, that el-cheapo chinese hubs are fine, as long as you don't use power-hungry devices on all ports.

  • Indeed, even a powered USB 2 hub seems to be sufficient for the purposes, or at least to improve things greatly. – Stephen Morgan Aug 10 '15 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.