0

I recently purchased a 3TB WD internal drive as a media storage. I thought this would be no problem since i have a UEFI Bios (ASRock P67 Pro3). After not being able to use any of the storage beyond 2TB (not even creating 2 partition totaling 3TB) i looked into the BIOS and SATA mode is in IDE. I assume that's why Windows disk management won't let me convert the MBR disk to GPT ? I'm using Win7 64bit.

So i changed SATA mode to AHCI and windows wouldn't boot up anymore. I boot from a crucial m4 CT064M4SSD2 which supports AHCI i believe. Do i have to re-install Windows ? Maybe its something i could do while upgrading to Win10 ? Is switching sata mode after installing supported in Win10 as opposed to Win7 ? i'd like to be sure the problem comes from not having AHCI mode on before nuking windows. I'd rather keep Win7 for now but i can upgrade too.

thx

1

There are two items here:

  1. AHCI and legacy IDE mode are independant of the bootrecord.
  2. MBR not working in most cases with >t2TB drives.

1 is easy. If you have a very old computer from the XP era or older, or if for some unknown reason you set IDE legacy mode before installing windows then windows installs and activates only the old drivers. Just enabling AHCI means you do have AHCI storage, but no IDE storage. AHCI storage and no enabled AHCI drives -> no working windows.

Solution: Turn on AHCI before changing the setting in the firmware. (regardless if thatr is BIOS firmware or EFI firmware).

2) MBR and normal disk are limited to 2TB. This has nothing to do with AHCI or legacy IDE. Changing those settings will not solve your problem.

Normally I woulc check if the data is backup and the backup works. Then wipe the disk with diskpart and start cleanly with a GTP bootrecord and a NTFS filesystem.

  • thx allot. all i needed to do was type 'convert gpt' in diskpart then disk manager let me create a 2.7tb partition. that is after manually preventing the pagefile from using the drive as windows had automatically switched to it even if it's the slowest... – Narcil Aug 9 '15 at 16:53
0

AHCI can be enabled after install of W7

In regedit navigate to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Msahci,

click "Start",

in the right pane modify value to 0

Do the same for

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV

Changing from RAID to AHCI, you need one more step. Msahci driver requires Atapi.sys miniport to be loaded during boot as well.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi

AMD raid systems http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/changing-from-raid-to-ahci/4c94f678-6bd1-48a6-b871-8872c841023a?page=2

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nvstor HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nvraid HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\amdsata (non raid)

Restart the PC, enter the bios and enable AHCI, save changes on exit, boot into Windows, it will install necessary drivers.

Resart PC again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.