I just added the latest version of the Eclipse IDE to my computer. Eclipse is distributed as a ZIP file, so I unzipped it into a directory in C:\Program Files like I've done for past versions of Eclipse. However, I also like a shortcut in the start menu. I don't see a way to make that happen.

After I extract the ZIP, one of the files is eclipse.exe. What I've done in the past is to right click on this file, create a shortcut, and drag it into the start menu's All Programs section and it lives there. When I do that in Windows 10, I get an icon that indicates that I can't drop it there (there's a red circle with a slash through it).

I then tried to pin the application to the start menu using the right click menu. It's not what I'm looking for, though:

start menu

I then found this question here on Super User and follow that instructions. I made a shortcut on the desktop to the application and then copied that shortcut into %appdata%/Microsoft/Windows/Start Menu/Programs:

location of shortcut

However, the result was identical to right clicking and pinning to the start menu - not what I want.

I don't want the Eclipse icon in the section on the right. I want it to appear in the section on the left, where Dia, Eclipse Luna, and other apps are listed. The three obvious solutions don't appear to give me what I want.

How do I do this?

As of 7 Sept 2015, I'm running Windows 10.1 Build 10240 and I still have this issue. I've tried the advice posted in the answers - putting the shortcut to the executable in the %appdata%\Microsoft\Windows\Start Menu\Programs and C:\ProgramData\Microsoft\Windows\Start Menu\Programs\ directories, yet no success getting the desired result.

I did try something new. I went to %appdata%\Microsoft\Windows\Start Menu\Programs (where the Eclipse Process Framework and Eclipse Luna shortcuts are located) and made a new folder called Eclipse. This folder appeared in the Start Menu. I copied the Eclipse Process Framework, Eclipse Luna, and Eclipse Mars shortcuts into this folder. The end result was this:

start menu 7sept15

Again, not what I was expecting to happen. The Eclipse Process Framework and Eclipse Luna icons went into the new folder, which is good. The Eclipse Mars icon stayed on the side, where I don't want it.

This is what the folder structure looks like:

C:\Users\Thomas Owens\AppData\Roaming\Microsoft\Windows\Start Menu\Programs

C:\Users\Thomas Owens\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Eclipse

I'd be curious to know if this is an issue that may be resolved in a later build. Unfortunately, I do like some level of stability, so changing to one of the other release streams isn't going to help me. But if someone can point to this being a known issue that has been confirmed as resolved in a later build, I'd be willing to accept that answer once the build flows out to the main release stream.

  • I created a PowerShell script that makes a shortcut. If I run it as a standard user the shortcut shows up on the right side. If I run it with enhanced privileges it shows up in the list on the left. However when I do that, the target vanishes for some reason that I haven't fully understood. So perhaps the problem lies with what user is adding the shortcut. Aug 30, 2015 at 6:31
  • @SmetadAnarkist Could you share your PowerShell script? Or perhaps information about how to create shortcuts with elevated privileges manually? It's been a month since I've asked this question and no one has provided an answer that actually works, so I'd be willing to try the script. Sep 8, 2015 at 0:03
  • You may want to look into Classic Shell, it works with Win 10.
    – Hefewe1zen
    Sep 8, 2015 at 1:44
  • @ThomasOwens I've based my script on the instructions in this article computerperformance.co.uk/powershell/… but as I said, the TargetPath property isn't getting set correctly. The IconLocation however is. Sep 8, 2015 at 5:45

2 Answers 2


So the pattern seems to be this:

If you have ever pinned a shortcut to start, then any shortcut later created to the same target, will also be pinned.

One solution: rename or relocate the shortcut's target.

For example, I had previously pinned a shortcut to VNC, so I couldn't get it to appear in All Apps. I renamed VNC-Viewer-5.2.3-Windows-64bit.exe to vnc 5.2.3.exe, and shortcuts created to it in Programs now appear in All Apps, instead of pinned.

Shortcuts to never-before-pinned targets, or renamed targets, will show up in All Apps. You may have to restart to see them, but they will show up.

Unfortunately, you don't seem to be able to unpin a shortcut in the sense of removing this association. Instead, unpin simply removes the shortcut, and if you put it back, that is treated as 'turning the pin back on'. I infer that there is a database of 'should be pinned' targets, located here:


I don't know any easy way to edit that, though. Perhaps if you used a hex-editor to change a letter in the target path in that file, it would fix it.

Other posters have suggested overwriting the entire TileDataLayer folder with a copy from a clean windows user, however that seems a bit dodgy to me.

  • 1
    This answer is correct. Unpin and remove the shortcut first. After you rename the app and create a new shortcut for it in the Start Menu folder, you can revert the app to its original name, and everything will still work. Detailed steps here.
    – mgiuffrida
    Jan 28, 2017 at 22:40

Right-click on Eclipse Luna on your start menu (on the left there in your screenshot) and choose "Open File Location". The file there is the shortcut, not the Eclipse executable. Move your newly created Eclipse Mars shortcut into the same folder as Eclipse Luna, and that should do it.

  • When I did this, the path is C:\Users\Thomas Owens\AppData\Roaming\Microsoft\Windows\Start Menu\Programs (which is the same as %appdata%\Microsoft\Windows\Start Menu\Programs). The Eclipse Luna and Eclipse Moon shortcuts are both already here. Aug 11, 2015 at 8:51
  • 1
    These two locations (mine and Robert's) are the per-user and all-user locations for things on the Start Menu. If they're not showing up on the Start Menu after putting them there, there's something wrong with your Windows install. That procedure is how I've created my Eclipse shortcuts for several versions of Windows, including 10 Tech Preview and 10 release. Are you on the release version, or a preview? And have you installed all available updates? I know there were a number of patches soon after release that fixed up some weird problems like these.
    – DarkMoon
    Aug 11, 2015 at 9:10
  • Oh, and when all else fails, try a reboot. shrug Maybe it's not refreshing the menu properly.
    – DarkMoon
    Aug 11, 2015 at 9:11
  • I rebooted with the shortcut in one location, nothing, moved the shortcut, rebooted, and again nothing. The results were always the tile on the left side and nothing in the alphabetical list. I'm running a fully updated Windows 10 release. Aug 12, 2015 at 8:56
  • I take it Eclipse Mars runs fine if you just double-click that? And if you go into the propeties of both the exe and the shortcut, do either of them have an "Unblock" button on the bottom of the first tab? Also, does the same thing happen if you create a new shortcut to something else and put it in the same folder(s) that we put Mars in?
    – DarkMoon
    Aug 12, 2015 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.