51

Have updated to windows 10 pro edition

In power options have sleep/turn off display - never when powered and 30/15 minutes when battery.

Computer is powered

Every time i go out for 1-2 minutes it go to login screen, broke all my opened ssh session etc.

Anyone have same? Any way fix it? Maybe there is somewhere logoff timeout option?

8
  • 1
    Have you checked the event log to see if you were logged out, or the system had an unexpected reboot?
    – Eris
    Aug 9, 2015 at 23:28
  • 1
    No, it not reboot. It just logoff, all applications are here and same state as before, just disconnected(seams like it go fast sleep mode). It is not one time behavour. That was 5 times over last hour.
    – arheops
    Aug 9, 2015 at 23:34
  • 1
    Checked windows event log. It show "The system is entering sleep.Sleep Reason: System Idle", by "kernel-power". However all settings in current scheme are "never"
    – arheops
    Aug 9, 2015 at 23:37
  • Did you find a solution to your problem ?
    – Fabske
    Dec 31, 2015 at 13:54
  • 1
    I also have this problem. Suddenly appeared after new Win 10 update.
    – Stefan
    Jan 2, 2018 at 13:22

4 Answers 4

47

This is most likely happening due to a hidden power option called System unattended sleep timeout. On my machine it was set to 2 minutes, which was mighty annoying, as it would cause behavior described by OP (sleep, wake-up, login screen, Event Viewer saying: "The system is entering sleep; Sleep Reason: System Idle"). You have to enable this option in registry before being able to change it.

From http://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/windows-10-keeps-going-into-sleep-after-1-minute:

  1. Click on the windows icon
  2. Type regedit
  3. Right-click on regedit icon, click Run as administrator
  4. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
  5. Double click on Attributes
  6. Enter number 2.
  7. Go to Advanced power settings (click on Windows button, write power options, click on Power Options, in the selected plan click on the Change plan settings, click on the Change advanced power settings).
  8. Click on the Change settings that are currently unavailable
  9. Click Sleep, then System unattended sleep timeout, then change these settings from 2 Minutes to 20 for example.

This solved the issue for me.

10
  • Not think so. It go away with windows 10 updates, after some times(new update?) apear again.
    – arheops
    Aug 2, 2016 at 15:16
  • @arheops, did you try this solution?
    – predi
    Aug 2, 2016 at 15:21
  • At current moment it work ok. Last time was not ok 1 month ago.
    – arheops
    Aug 2, 2016 at 19:49
  • 1
    Did not work. -1
    – Gnemlock
    Nov 22, 2017 at 23:48
  • 3
    I'm sure they at Microsoft had a good reason to implement this nonsense Jul 31, 2018 at 6:54
18

There is a screen saver setting hidden in the old Control Panel from previous versions of Windows. To get to the setting, follow the steps below:

  1. Open the start menu up and search for "Control Panel"
  2. Go to "Appearance and Personalization"
  3. Click on "Change screen saver" underneath Personalization on the right (or search in the top right as the option appears to be gone in recent version of windows 10)
  4. Under Screen saver, there is an option to wait for "x" minutes to show the log off screen (See below)

If you uncheck the checkbox, you should be able to prevent your computer from logging off.

3
  • no,it is not. this one also disabled.
    – arheops
    Sep 28, 2015 at 19:14
  • If this option is disabled, go to the group policy editor (gpedit.msc), then: User Configuration->Administrative Templates->Control Panel->Personalization And there you have the screen saver settings (note that "Enable Screen Saver" supersedes most of them) Nov 13, 2018 at 18:21
  • This was it for me. I thought having the Screen Saver set to "None" would disable the logout but I guess you need to uncheck this as well. Thanks! Jan 17, 2019 at 22:32
5

For those of you that end up here and still experience Windows 10 locking the computer, even after following @predis answer: have a look in "Sign-in Options" by pressing WIN key then typing Sign-in Options, then scroll down to Dynamic Lock and un-check the Allow Windows to lock your device automatically when you're away-option. As in the picture below.

enter image description here

This option seems to superseed any option you have in Power Settings.

5
  • It is not solution. Disable lock is bad idea.
    – arheops
    Feb 11, 2019 at 14:12
  • 1
    Really, please elaborate.
    – Ole Aldric
    Feb 11, 2019 at 15:35
  • 1
    Lock can be used for prevent authorized access. Lock used in most cases for sleep box. Question was not "how to disable lock", but "How make windows respect my choice"
    – arheops
    Feb 11, 2019 at 17:39
  • 2
    Yes, and for some (including me) this was the last setting (after changing all the above mentioned) that finally made it work. What you are asking for is just as "dangerous" as this. I don't see why you give me -1.. I mean, do you know that this setting actually do?
    – Ole Aldric
    Feb 12, 2019 at 7:49
  • arheops is objecting to a specific issue (how to make windows stop the behavior) based on a very general principle (security). Yes, we know. we want to disable it anyway. This is like asking where to buy alcohol, and then someone coming in and saying alcohol is unhealthy for you. thank you, no thank you, we know.
    – ahnbizcad
    Jan 6, 2021 at 23:43
1

Another possible answer: increase the sleep timeout.

enter image description here

Control Panel -> Hardware and Sound -> Power Options -> Change plan settings -> Change advanced power settings

3
  • Not a case, sleep timeout was 30(i say in question)
    – arheops
    Dec 28, 2018 at 1:11
  • 1
    I don't have this settings in the plan options, I only have the 4 other things under "sleep"
    – Ferrybig
    Oct 21, 2019 at 15:39
  • I think one also need to modify reg value as some of the answer describes. I did both and check if it works for me.
    – Deep
    Mar 19, 2020 at 13:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.