1

Every time I type class in a html file in Visual Studio the app stops responding for a few seconds, presumably it's building the intellisense list of classes available. How can I disable this?

Strangely this is on a fresh install of VS2013 on a fresh install of win 10. It was not lagging like this when I was running under Win 8.1 even with a number of extensions running.

4

I discovered that this the auto-completion for CSS classes can be turned off by going to Tools->Options and in the Options dialog going to Text Editor->HTML->General and unchecking 'Auto list members' as shown in the screenshot below.

enter image description here

|improve this answer|||||
  • Thank you so much, this problem has been bugging me for months now (so much so that I would sometimes copy & paste CSS classes from notepad into visual studio just to avoid the lag). – Omar Himada May 18 '16 at 17:46
  • great, happy this helped someone else. it was a huge annoyance – Chris Herring May 19 '16 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.