1

I have installed Metasploit Framework on Mac OS X Yosemite running Ruby 2.1.6 using the instructions here.

It gives me an error when I try to run it:

/usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:370:in `parse':     (/usr/local/share/metasploit-framework/config/database.yml): mapping values are not allowed in this context at line 3 column 11 (Psych::SyntaxError)
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:370:in `parse_stream'
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:318:in `parse'
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:245:in `load'
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:464:in `block in load_file'
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:464:in `open'
from /usernames/username/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/psych.rb:464:in `load_file'
from /usr/local/share/metasploit-framework/lib/msf/ui/console/driver.rb:172:in `initialize'
from /usr/local/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
from /usr/local/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
from /usr/local/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
from /usr/local/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
from /usr/local/share/metasploit-framework/msfconsole:48:in `<top (required)>'
from /usernames/username/.rvm/gems/ruby-2.1.6/bin/msfconsole:23:in `load'
from /usernames/username/.rvm/gems/ruby-2.1.6/bin/msfconsole:23:in `<main>'
from /usernames/username/.rvm/gems/ruby-2.1.6/bin/ruby_executable_hooks:15:in `eval'
from /usernames/username/.rvm/gems/ruby-2.1.6/bin/ruby_executable_hooks:15:in `<main>'

Is there any fix for this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.