8

I get this error when installing Windows 98 Second Edition on virtualbox. my host is Mac OsX. install error

the guest settings are the following:

Base memory: 64 MB
Boot Order: Floppy, Optical, Hard Disk
Acceleration: VT-x/AMD-V, Nested Paging
Video Memory: 10 MB

Why I am getting that error and how can I bypass it?


EDIT:

Also get these errors when i click on close:

W98SETUP caused a General Protection Fault in module GDI.EXE at 0001:0246

W98SETUP caused a General Protection Fault in module USER.EXE at 0001:40B6

Standart Mode: Bad Fault in MS-DOS Extender.
Fault: 000D Stack Dump: 000 000 0070
Raw fault frame: EC=000 IP=5EF7 CS=0367 FL=3087 SP=FFEE SS=02C7
8

I'm guessing this is a bug in VirtualBox 5.0. I haven't reported it yet I'll get around to it but for the time being I downgraded to version 4.3.28, and the old Windows boots fine.

Update: This should be fixed by VirtualBox 5.0.22, although I haven't tested yet.

  • 1
    Installing virtualbox 4.3.28 solved my problem. thank you very much – DiogoSaraiva Aug 10 '15 at 20:24
  • Yes, it’s fixed. Works for me in VirtualBox 5.0.26 as well as 5.1.6. – aaronk6 Sep 25 '16 at 8:36
14

Problem:

Windows 98SE is incompatible with the newer hardware that VirutalBox virtualizes; specifically when hardware resources are passed-through from the host directly.

Solution:

In VirtualBox, disable the hardware acceleration for that VM.

To do so:

  • Right-click VM.
  • Choose Settings.
  • Choose System.
  • Choose the Acceleration tab.
  • Un-check Enable VT-x/AMD-V.
  • Save changes, try again.

enter image description here

  • same thing.... same error – DiogoSaraiva Aug 10 '15 at 12:32
  • 1
    I tried also with 300mb of disk, but the second error is: Standard Mode: Invalid DMPI return from 0367:5F92 – DiogoSaraiva Aug 10 '15 at 12:35
  • 1
    This answer solved the issue for me using a Linux host. – Tom B Oct 12 '15 at 13:00
  • 1
    This answer solved the issue while installing Win 98 SE (fr) on a Windows 8.1 host - VirtualBox 5. – AlexV Feb 10 '16 at 15:34
  • 1
    This answer helped me. – aryndin Mar 14 '16 at 8:18
5

I was able to get around this error by using the Paravirtualization setting to Legacy (found under System => Acceleration in the VM settings).

0

A default install of Virtualbox on Mac OS X assumes VT-x availability. This is because all of the Mac hardware lineup supports it. In order to disable VT-x extensions to allow a Windows 98 to install/work, do this in a Terminal window (sub in your machine name inside the quotes):

VBoxManage modifyvm "My Windows 98 VM Name Here" --hwvirtex off

Source: http://blog.vaibhavbajpai.com/2012/12/17/disabling-vt-x-on-virtualbox/

protected by Community Jan 21 '16 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.