27

I have been disabling the 'use default gateway for remote networks' option to bypass unnecessary traffic from going through vpn. But after upgrading to Windows 10 I can't change the setting since the IPv4 Properties does not open up when I click it.

enter image description here

Is there any other way to access this setting?

6
  • 4
    If the IPv4 properties don't open, then I'd say you probably have a bigger problem that you should be concerned about first. Aug 10, 2015 at 15:35
  • 4
    @Ƭᴇcʜιᴇ007 well, he isn't alone with that problem. I have a fresh Windows 10 Installation here and the Properties button does nothing. There a number of TechNet Topics but so far, silence from Microsoft.
    – enzi
    Aug 18, 2015 at 15:45
  • This was a bug. It was fixed in TH2. See related answer here. Mar 14, 2016 at 13:00
  • How did you even get to this dialog box in Windows 10? I can't find anything like this in the current version of Windows. May 17, 2018 at 22:44
  • @JonathanWood Easiest way is to go to Control Panel-> Network and Internet-> Network and Sharing Center-> Change Adapter Settings (on left)-> Right click any adapter and select properties. You will see a dialog like this open up with Networking Tab on it.
    – AsifM
    May 17, 2018 at 22:49

3 Answers 3

28

You can use this powershell command to enable/disable default gateway on VPN:

Set-VpnConnection -Name "myVPN" -SplitTunneling $True
5
  • Tried earlier, but my tracert goes always through VPN, even after applying this command. And yes, I know name of "myVPN". :( Sep 1, 2015 at 10:45
  • 1
    what if I am using VPN Client called 'FortiClient' ? I can't list or set config using this above command. What is the solution for that.
    – Paresh
    Mar 14, 2016 at 21:09
  • 2
    Something is missing here. What does True mean? Do, or do not, use the remote default gateway? Jan 11, 2017 at 10:51
  • 1
    $True mean this setting will be enabled, default value in windows is $False
    – Madmucho
    Apr 7, 2017 at 11:47
  • I tried this, and it resulted in no traffic going through the VPN at all, not even the VPN-only sites -.- Oct 10, 2017 at 10:53
9

If you go to here: %appdata%\Microsoft\Network\Connections\Pbk\rasphone.pbk open with text editor and for every Vpn connection listed change IpPrioritizeRemote=1 – change this to 0 to disable

2
  • Nice, the tool is cool when run from win+r by rasphone.
    – Qwerty
    Jun 13, 2016 at 14:10
  • Great answer. But now I found that the VPN I'm using automatically changes this back to 1 when connecting. How can I prevent that? Oct 2, 2019 at 9:44
1

source: https://windowsreport.com/vpn-split-tunneling-windows-10/

try one of:

  1. Edit the VPN connection properties enter image description here

  2. Use PowerShell

    Set-VPNconnection -name "Your VPN connection" -SplitTunneling $true
    

    enter image description here

2
  • Are these 'either-or', or 'both-and'? (Number 2 on its own looks equivalent to the accepted answer.)
    – mwfearnley
    Jun 20 at 15:46
  • 1
    @mwfearnley either-or Jun 20 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.