12

Under Windows 10, I can no longer drag around a window that is pseudo-maximized. For example, a Remote Desktop window that is 'maximized' to its maximum size of 1280x1024 (per my .rdp file) must be restored down to a smaller size, then dragged, then restored up even though the window itself is not maximized to the monitor's workspace area. This was previously not a problem in Windows 8.1 (or other versions of Windows).

I've done my due diligence with some research. Here are some things I have investigated and found to not be a cause or helpful:

  • Windows' AeroSnap settings or availability
  • Video driver features or settings
  • Other third-party monitor or taskbar utilities

Any software I have that is maximized in this way is locked and must be restored down before I can drag it now including the aforementioned Remote Desktop, a few games I play in windowed mode, etc. Other applications that are not maximized of course do not have this issue.

A test application can be built in .NET to demonstrate this issue. Simply build a WinForms application with a Form.MaximizedBounds of an arbitrary value like 500,500 and have the form maximized on launch (Form.WindowState = Maximized). Under Windows 8.1 (and earlier), it can be dragged around the screen without issue, however under Windows 10 it cannot.

Anyone know what gives and if there are any workarounds?

  • I seem to be able to drag fixed-size windows without a problem on my Windows 10 machine. Are you using a single monitor per-chance? Because I am using multiples. – Arthur Kay Aug 10 '15 at 17:39
  • This is a triple monitor setup arranged horizontally (as it was under Windows 8.1). I'm welcome to suggestions on stuff to try. Be aware, that fixed-sized issues aren't the issue, it's specifically an issue with windows that are maximized. – psouza4 Aug 10 '15 at 17:45
  • Just to chime in. Windows 10 maximizing RDP to its restricted size I am able to move it around. – Unfundednut Aug 12 '15 at 17:19
  • This is a clean Windows 10 install (not an upgrade) from a freshly-formatted drive with mostly default settings and nVidia display drivers via GeForce experience using default settings. If you can suggest a setting I can adjust that will fix this, please provide an answer so I can verify and award the bounty. – psouza4 Aug 12 '15 at 17:24
  • 1
    FYI I created a .NET Windows Forms Application with MaximizedBounds = new Rectangle(500,500, 500, 500); WindowState = FormWindowState.Maximized; and I am able to drag it from maximized mode. The window immediately gets reduced to normal and moves where I want it to. (.NET 4.6) – Mik Aug 18 '15 at 7:31
2

I know that this is an old topic, but one that has plagued me since switching to Windows 10, and I just solved it last night. So I'm answering this to possibly help other folks.

First, my situation. I manage about 16 servers from my home office. I have created saved RDP connections for each server to my desktop. Each day, I log onto each server using these connections to check logs, hardware status, etc. I do them all at once, so at least once a day, I have 16 RDP windows open at once. The constant downsizing, and snapping to the screen edge, was driving me insane!

Here is what I did to fix it...

By right-clicking each saved RDP connection, and selecting 'open with' and then choosing Notepad, you can get to a plain text file that defines the RDP connection (as opposed to the typical GUI RDP properties panel). On each of my saved connections, I changed the following 4 parameters: screen mode id, desktopwidth, desktopheight and winposstr! Here is what they look like on one of my typical saved RDP connections:

screen mode id:i:1
desktopwidth:i:1280
desktopheight:i:1024    
winposstr:s:0,3,1575,160,2900,1230

Screen mode id must be set to 1. That makes the remote session appear in a window.

Desktop width and height are self explanatory...but they can be anything so long as they're smaller than the screen you're viewing them on.

Winposstr is the important one. When you open your saved RDP connection file, the fifth and sixth values of this parameter will be much smaller in comparison to the third and fourth parameters than they are in my example. You have to edit those last two values...make them bigger! To get your RDP window to open full size, you have to add your desired vertical and horizontal resolution (plus a bit extra) to the third and fourth numbers respectively. So, 1575+1280=2855. If you put that number in for the fifth value, exactly, you'll still get scroll bars. So in this case on my system, I put 2900. Likewise, 160+1024=1184. 1200 still gave me scroll bars, so I tried 1230, and it worked.

I haven't taken the time yet to figure out exactly what the third and fourth numbers represent. It's obvious they're somehow defining the position of the window on my screen, but I just haven't figured out that exact relationship. And those numbers will probably be different for you...when you save your own RDP connection file, they'll probably vary because you have a different setup than I do. But the point is, you have to add the horizontal and vertical resolutions of your desired RDP window to the third and fourth number, whatever they are, PLUS a bit extra, and then replace the fifth and sixth number with the results you get!

Once you've made the change, save the file, and close it. Then when you double click that RDP connection, it should open full size, and be able to be dragged to whatever position you want, without automatically downsizing!!!!

On my system, the upper left corner of the RDP session defined by the parameters above will be 0 pixels down from the top of my screen, and 3 pixels from the left edge. You can change the initial position by editing these values...for example, 10,10 would put it 10 pixels down and ten from the left. But if you add to these values, you ALSO have to add to the 5th and 6th values as well. Like I said, I haven't figured out the exact relationship yet...just know that if you change these, you may have to increase the 5th and 6th values as well to avoid scroll bars.

Finally, on my system, I have the 'Prevent Windows from being Automatically Arranged when moved to the edge of the screen' parameter UNchecked (this is in the 'make mouse easier to use' section of the Ease of Access Center).

| improve this answer | |
  • Welcome to Super User. Reading your answer its clear you have a working solution, however Super User is a Q&A site (vs. a forum) and answers are expected to avoid conversational details. Please edit yours to focus more on the specific steps needed to implement your solution. Too much detail makes it difficult for other users to put your answer to use. Thanks for contributing. – I say Reinstate Monica May 5 '17 at 20:16
  • Unfortunately, this is also not an acceptable solution for the described problem, which is specific to Windows 10 and not terminal services/remote desktop. While the problem is seen with RDP sessions, it's also seen in other apps (as described in my post). Additionally, the 'prevent windows from...' setting in your comment is part of AeroSnap, which has already been discussed. While you may have discovered a work-around for one application (RDP sessions), it does not fix many others that are also pseudo-maximized and thus can't be accepted. Thank you for the detailed attempt. – psouza4 May 6 '17 at 19:58
0

First some background information. I often use multiple RDP sessions to connect to different remote systems at the same time. Each RDP window is configured to be 1280x768 on my system that has two monitors where each monitor is 1920x1080.

On Win 10, when I open a RDP seesion, the psuedo-maximized window is stuck in the top-left corner and cannot be dragged anywhere. As you reported, RDP windows behaved differently on Win 7 and 8.

However, I have recently discovered a workaround.

On Win 10, after opening an RDP session, "unmaximize" the RDP window. It becomes half-size with horizontal and vertical scroll bars. Manually resize the half-size RDP window until the scroll bars disappear. Now you can drag the manually "pseudo-maximized" RDP window anywhere, just as you could on Win 7 and 8. Be careful, though. If you accidentally double-click the title bar, the RDP window jumps back to the top-left corner, automatically "pseudo-maximized" and becomes immovable again.

Although not a perfect workaround, it is one I can tolerate.

| improve this answer | |
  • This answer does not resolve the issue with all pseudo-maximized windows. See my original post using a sample application unrelated to RDP sessions and other comments. The focus isn't RDP sessions. – psouza4 May 6 '17 at 20:00
-1

If I take your comment to be the most accurate information, we have a situation where the window size will not retain its maximized state while being moved, but does not require you to minimize it first as originally stated in the question.

Assuming the above is true, the workflow I use in a multi-monitor setup (which works on Windows 7, 8, and 10) is dragging the maximized window from its current location (thus causing the window to resize to a smaller size), to the top of the other screen, which places the window back to its maximized state. This also works to maximize a window that's not already maximized.


If the above is not an acceptable workaround, and you've exhausted experimenting with the options in Multitasking > Snap, then perhaps a registry edit will resolve. The same WindowArrangementActive entry that controls Aero Snap as detailed in this answer: https://superuser.com/a/222609/61471 exists in Windows 8 and 10.

| improve this answer | |
  • Unfortunately, I believe my original question and the comments attached to it describe your answer as an unacceptable proposal. The behavior seen in prior versions of the Windows OS (pre-Windows 10) would allow the window to be dragged in its fully-maximized state (pseudo-maximized, such as a hard-maximized RDP window) without any change in its maximized state and with Windows Aero disabled. Even in a non-multimonitor setup, The pseudo-maximized RDP session could be dragged from one region of the screen to another without a window sizing change. It's no longer the case in Windows 10. – psouza4 Nov 18 '15 at 7:21
-1

Just found the answer. Had the same problem myself. In the system properties, click on multitasking. Then turn on "Arrange windows automatically by dragging them to the sides or corners of the screen" Solved this issue of locked Maximized web pages on each monitor. 3 monitor setup here. Hope this helps.

| improve this answer | |
  • This is not a solution for the described problem whatsoever. The setting in your comment is part of AeroSnap, which has already been discussed. The problem is prevalent in pseudo-maximized windows (windows that are in the maximized state while not filling the entire monitor, such as RDP connections). – psouza4 Jan 23 '17 at 22:48
-1

We are some years ahead in the future and I have an easier solution for you. Edit the saved .rdp file with note pad and add below 'smart sizing' line, to have the RDP session window be maximized to the resolution that you specified.

smart sizing:i:1

| improve this answer | |
  • Can you elaborate on this a little more? – Toto Jul 25 '18 at 12:56
  • This may be a workaround to one program, but does not correct or substitute the desired behavior. RDP was one such example that's readily testable across Windows, but was not the only offending app. – psouza4 Jul 27 '18 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.