6

In Windows 7 I used to have my Sound set up that I had my Headset plugged in at my front audio ports, and my speakers plugged in in the rear. I used to use the "Playback Devices" menu to switch the default playback device depending on what I needed.

When switching to Windows 10, the updater/setup automatically installed a "Realktek HD Audio Manager" (which is the manufacturer), however that driver removed the ability to do that. I can now no longer switch devices in the Playback devices, both front and back connectors are the same "device". I have to use the Audio Manager in an annoying way.

I tried uninstalling the the Audio Manager, and that works for a short time, but apparently Windows reinstalls it every time. Is there a way to work around the Audio Manager screwing up my sound management. Another way to help me would be to figure out how to avoid Windows reinstalling that application every time without asking me. Is there a way to do one of those two things?

Edit: I actually like the automated installation of most drivers on the system. The problem lies with that one, so disabling ALL automated installation isn't really what I wanted.

7
  • Does the old Realtek driver/control panel work for you correctly when reinstalled? Mine was totally silent until I installed the new Win10 version, but that lost all the 5.1 setup, delays, EQ etc that I used to rely on with the older version. – Tetsujin Aug 11 '15 at 8:08
  • @Tetsujin I wouldn't know. I didn't have the old Realtek control panel installed before Windows 10, and Windows 10 just automatically installed it (over and over and over again). I found a workaround with the control panel and will post it later – private_meta Aug 11 '15 at 8:37
  • 2
    Here's how to permanently get rid of the Realtek driver: ① disable, disconnect or unplug any internet connection to prevent Windows from reinstalling the driver, ② uninstall "Realtek High Definition Audio Driver" and restart to make sure it's gone, ③ go to C:\Program Files and create a new folder called "Realtek", ④ open the properties dialog, go to the "Security" tab and click on "Advanced", ⑤ click on "Change Permissions", then "Disable inheritance", and in the new dialog select "Remove all inherited permission from this object", ⑥ click on "OK" and "Yes" etc. to apply the changes. – Livven Jan 16 '18 at 23:02
  • Now you can reconnect to the internet and Windows will not be able to reinstall the driver because it does not have permission to access the installation folder. To undo this and get the Realtek driver back: double-click the "Realtek" folder you created, choose "Continue" to restore access and delete the folder. If necessary go to Device Manager and update the driver from there if it doesn't install automatically. – Livven Jan 16 '18 at 23:02
2

Try Microsoft's tool to Show/Hide Updates.

  1. Uninstall the driver

    1. Press Win+x, and then click Device Manager
    2. Find the driver, and click Uninstall
  2. Run the troubleshooter package from Microsoft

    1. Follow the instructions, and disable the Realtek driver update
2
  • This method unfortunately did not work for me, however I've found another way that works. See this comment. – Livven Jan 16 '18 at 23:08
  • Thank you so much, this worked for me. The sound is not only better after that. It also takes care of a very annoying error with Spotify where it won't be able to continue playing sound after I unplug and plug again my headphones. – julkiewicz Feb 10 '18 at 22:10
2

I was able to use the following steps to simulate Windows 7 style Audio Behavior without actually being driverless (and thus not having any sound at all). This is one of the solution, the other one being by geek1011.

In the Realtek HD Audio Manager, go to Connector Settings, and switch to the device that is responsible for your speakers. Also disable Auto Popup dialog. enter image description here

In the advanced device settings set the options for two different audio streams and separate all input jacks. enter image description here

In Windows, go to the Action Center, All settings, System, Notifications & actions. There, turn off notifications by the Realtek HD Audio Manager and hide the realtek manager from your taskbar.

2
  • That was the Panel I was unable to find, btw - got it now, though it took some finding ;-) – Tetsujin Aug 12 '15 at 8:04
  • Note that there is a way to prevent Windows from reinstalling the Realtek driver, see this comment. – Livven Jan 16 '18 at 23:08
1

Note: I am on a Dell G7 and these steps may be slightly different for your machine.

  1. Use Add/Remove programs to uninstall the Realtek driver (if it exists)
  2. Reboot
  3. Let Windows install the drivers automatically from Windows update (to verify this, you should see your audio device working and showing up as Realtek)
  4. Open Explorer and navigate to C:\Windows\System32\DriverStore\FileRepository (this is where Windows 10 keeps the driver update files)
  5. Sort by Date modified, and you should see multiple folders modified very recently (there may be non-audio-related files here, so be careful)
  6. Find all of the relevant folders for the audio drivers

    in my case:

    • hdxdellsstcsmb2018.inf_amd64_e3e1faa54cd2ea1c
    • wavesapo.inf_amd64_043a570d84e7e965
    • wavesapo75de.inf_amd64_5ff36f834a6d461a
    • dellaudioextwaves.inf_amd64_a8fc1a4f86ac4fa9
    • hdx_dellcsmbext_waves.inf_amd64_37d08961dc33a03e
    • hdx_dellcsmbext_waves.inf_amd64_de3d27adc6ebf608
    • hdxdellcsmb2018.inf_amd64_0cf5b01244c7b3dc
    • realtekservice.inf_amd64_fcea3531959f3bc4
    • realtekasio.inf_amd64_b061b3594ae23953
    • realtekapo.inf_amd64_4748908cf13baa19
  7. For each of these folders, follow the instructions by @Livven on the original post to change the inherited permissions: Keep the Realtek application off my computer in Windows 10 (note: I also had to change ownership to my user)

  8. Go into each folder and delete all of the files inside them
  9. Once complete, run Windows Update. It will complain that it cannot update the drivers because of permissions
  10. Run the Microsoft “Show or Hide Updates” troubleshooter: https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-window
  11. You should see the Realtek updates in the troubleshooter. Select them and hide them.
  12. Reboot
  13. Note: this step may be specific to Dell machines.

    In order to get the Microsoft High Definition Audio Device to install and work properly, I had to install the Realtek driver from Dell's website for my machine. I then rebooted and uninstalled the Realtek driver. This switched my audio driver back to Microsoft's. I then rebooted again, and can confirm that Windows update will not automatically install the Realtek driver (because the folders are access restricted and the Show or Hide update troubleshoot has hid them).

Enjoy!

Edit: this should also cover Make Windows 10 stop installing driver software automatically

6
  • Your link to your post is busted. Always quote the most relevant part of an important link in case the target site is unreachable or goes permanently offline. You do have enough rep to answer. Your Step 7: "follow the instructions": Always quote the most relevant part of an important link in case the target site is unreachable or goes permanently offline. I did not have to take ownership. Why did you have to?, how did you go about it? and why is that not in your answer? Your answer needs clarity. – somebadhat May 9 '20 at 14:17
  • @somebadhat: Removed link. Step 7 links to this post, so if it is unreachable or goes permanently offline, then there's no hope anyway (lol). As for taking ownership, that's not the point of this post and therefore I didn't include it. There are plenty of resources available to find out how to do that. – Parad0xD9 May 10 '20 at 18:55
  • cant change those folders even as administrator – stackOverlord Jul 11 '20 at 6:06
  • @stackOverlord: you'll have to right click the folder, click Properties, select the Security tab, click Advanced at the bottom, then you can click Change next to the listed owner. – Parad0xD9 Jul 12 '20 at 0:26
  • 1
    then in the Select User or Group dialog that pops up, click advanced, Find Now, and you can select your user account. Then click OK, OK, follow the steps to disable inheritance as instructed by @Livven, and you should be good to go. – Parad0xD9 Jul 12 '20 at 0:27
0

Here's a way of removing it the way you're wanting to.

  1. With Realtek still installed go to the task manager and find "Realtek Audio Driver" ("Rltk" or look for their speaker emblem) on the list of applications.

  2. Then open the application's properties and go the Security Tab and click the Advanced button near the bottom.

  3. From there you'll want to remove everything from that list (it removes all permissions from Realtek Audio).

  4. Then uninstall the Realtek Audio Driver from the Add or Remove Programs menu or the Device Manager.

Now, when you restart your PC, it will not have permission to reinstall itself and Windows should activate their default audio driver to replace it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.