1

I have somehow gotten Shift+E, (something) mapped as a keyboard shortcut in Visual Studio 2013.

I did a clean install of Windows 10 a couple days ago and finished installing Visual Studio Professional today. I think - but I'm not positive - that this problem didn't exist at first. I had just started typing in Visual Studio when I think I somehow triggered Windows Narrator with a keyboard shortcut. The reason I think I triggered Narrator is something flashed across the screen then I got a blue rectangle surrounding the editor window that had the focus. That blue rectangle stayed visible on the desktop when I minimized Visual Studio. No amount of poking around in Settings would get rid of it. At one point, my keyboard was acting like the keys were stuck, and trying to type would cause focus to jump from one program to another. It took a reboot to get things back to normal. I don't know if this was related, but I suspect I re-assigned a keyboard shortcut while everything was going wonky.

After the reboot, it took me a couple minutes to realize I couldn't hit Shift+E anymore. When I do, Visual Studio waits for the second key of the chord. I've tried going into the Keyboard Options and clicking Reset. I've tried uninstalling Visual Studio (without deleting any leftover files) and re-installing. I've disabled the extensions I installed (but left the ones that come with Visual Studio). No joy.

Any ideas on how to either figure out what Shift+E has gotten assigned to or to reset this assignment?

4

You have installed Powershell Tools for VS2015, haven't you?

It looks like they assigned Shift+E by mistake to one of their commands.

In Tools > Options > Environment > Keyboard, find command EditorContextMenus.CodeWindow.PowerShell.ExecuteAsScript and de-assign the shortcut.

| improve this answer | |
  • You are a lifesaver. I don't think I installed Powershell Tools the last time I installed Visual Studio, and I only installed them this time thinking I might do some experimenting. I guess I should have listened to my mother when she warned me of the dangers of experimenting. And interestingly, on my machine, that command shows in the list twice - once with the shortcut Shift-Alt-E, F5 and the other with the shortcut Shift+E, F5. – TheOtherTimDuncan Aug 11 '15 at 13:37
  • @TimD – regarding the command listed twice: You are not alone. – miroxlav Aug 11 '15 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.