2

EDIT: Please read what I have already tried before commenting/answering. Thank you.

I just found a completely ridiculous problem. I have Win10 on my laptop. It comes with .NET 4.5 installed but not 3.5. I want to run a game that uses 3.5 (it won't run without it). When I run either the online or offline .NET 3.5 installer, it says I need .NET 3.5 to install .NET 3.5!

Ridiculous error is ridiculous

This is extremely frustrating. Is there a way I can manually install it?


Things I have tried:

  • Running the .NET 3.5 Online Installer (2Mb)
  • Running the .NET 3.5 Offline Installer (237Mb)
  • Using dism.exe as per Method 3 listed here (it says The referenced assembly is not installed on your system.)
  • Running the .NET Verification Tool.
  • Refreshing my Windows (it fails and says nothing has changed)
  • Troubleshooting the installer (it says Incompatible program, which is wrong because I have .NET 4.5 installed)
  • Installing .NET 2.0 (apparently I need .NET 3.5 for that too)

None of these work! Any ideas?

  • 1
    Hit "install this feature" – Ramhound Aug 10 '15 at 20:35
  • @Ramhound It says The referenced assembly is not installed on your system. when I click that too. – Pyroglyph Aug 10 '15 at 20:37
  • You have tried installing it through the add windows feature? – Ramhound Aug 10 '15 at 20:40
  • @Ramhound I tried adding it through Windows Features but it fails saying The referenced assembly is not installed on your system.... – Pyroglyph Aug 10 '15 at 20:43
  • 2
    Sounds like you may have file system corruption. Run a CHKDSK, then run an SFC /Scannow, and if/after those report no problem found (and/or all problems fixed), try it again. – Ƭᴇcʜιᴇ007 Aug 10 '15 at 20:48
0

To install .NET 3.5 on Windows 10, you need to use Windows Features, and specific the source install files (i.e., the DVD or USB you installed from). I use this command most of the time (from an elevated command prompt):

dism /online /enable-feature /featurename:netfx3 /all /source:d:\sources\sxs

Substitute d:\ for your DVD or USB drive, and you should be good to go.

  • I already said this didn't work in my list of things I had tried. It says The referenced assembly is not installed on your system.. – Pyroglyph Aug 11 '15 at 14:12
  • Sorry, hadn't seen that in the original post, only that you jad tried the GUI. :-( – DarkMoon Aug 12 '15 at 1:03
0

The only way I've found to fix this is to redownload the Windows 10 Installation Media and install Win10 from scratch.

0

.NET 3.5 should already be included with the installation of Windows 10. You can enable it in Windows Features. Try following the steps in this link

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.