OS - Windows 10 64bits Laptop - Dell LCD monitor - Samsung Cables - HDMI to VGA adapter

second desktop only not working - Both Lcd monitor and laptop black, sound no problem and lcd monitor led light is on.

Note - Duplicate screen and extended work fine only second desktop only not working. Before this everything is working, this happen suddenly

Tests - Tested on another Samsung monitor and TV with same HDMI to VGA adapter it works prefect. So i guess it is my Samsung LCD monitor problem

Any idea how to fix this?


I manage to make "second screen only" works but something goes wrong.

First i have to turn monitor plug off and unplug hdmi to vga cable then switch my laptop win + p to "second screen only" then follow by plugin hdmi cable and turn on monitor plug on and now it works. It not work if I turn on the monitor first and connect hdmi second. If my screen sleep after mins or I switch to another mode and come back to "second screen only" then problem comes again.

Update 2 I tested my laptop with same cable on another same model Samsung monitor and it works perfect. The only different is when I connect to the "problem" monitor it automatic pick up "Extend" mode and the other monitor it pick up "PC screen only" mode at first. So is my laptop keep some hdmi memory? anyway to clear the memory in windows?

  • Sometimes displays do not handle adapters well, depending on the type. I have seen it a few times. Are you trying the same cable on the same type of display, but a different unit? – Dupree3 Aug 11 '15 at 13:26
  • yes, same cable different devices because I got only 1 HDMI to VGA. I found another thing. Please check my updates, see if u got any hints. – vzhen Aug 11 '15 at 15:10
  • If you are going from HDMI to VGA, the computer might not like that as it is not getting a HDCP handshake. – Unfundednut Aug 11 '15 at 15:15
  • What do you mean by "might not like that" ? @MrStatic – vzhen Aug 11 '15 at 15:18
  • If for some reason HDCP is required, that isn't possible with a HDMI->VGA adapter. So it won't allow the screen to work. Also as @Dupree3 has pointed out adapters like this don't always work. – Unfundednut Aug 11 '15 at 15:30

Just disable the display driver and re-enable it.

It's as simple as that.

(Of course, you should have your drivers updated.)


I got the solution.

Delete the Connectivity and Configuration under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers in registry

Remember to back up both key before deleted.

For more detail pls check here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.