39

I upgraded from Windows 7 to Windows 10 recently, and am looking to burn some .iso files. In Windows 7, there was a default program that I could use. I have dug around a bit, but cannot find one in Windows 10 so far. Although, a bunch of search functionality seems to be disabled on my machine, so I may just be searching incorrectly.

Is there a disc image burning program bundled in Windows 10 like there was in Windows 7?

Image of what I see:Explorer

1
  • This has been a feature of Windows since Windows XP. You have been able mount .ISO since Windows 8.0
    – Ramhound
    Aug 11, 2015 at 13:43

3 Answers 3

61

If you single click an ISO file using File Explorer "Disk Image Tools/Manage" shows up in the ribbon (much like MS office 2007 and later). If you click on "Manage" two options should appear below. Selecting "Burn" will give you the tool that you are looking for.

You should also be able to right click the file and select "Burn disc image" in the menu.

Example

If you have a program like VCD associated with ISO files the options above will not show up.

Supplementary trick: to restore the tab showing up in the ribbon, you do not need to un-install anything: just reassociate .ISO with Explorer (right-click on any .ISO, Open with... submenu, select File Explorer and check the Always use... box; you can do the same thing with the Associate control panel).

9
  • 8
    I don't seem to have a Manage tab, just File|Home|Share|View. When I right click on it, there is also no option to burn. I've added a link to what I see in the OP.
    – user403574
    Aug 11, 2015 at 6:15
  • 1
    I have the Pro version. I had W7 Professional before the upgrade as well.
    – user403574
    Aug 11, 2015 at 6:20
  • 4
    Shot in the dark here but it could be the association with virtual clone drive that is causing the options I mentioned not to show up.
    – Solitz
    Aug 11, 2015 at 6:26
  • 35
    Supplementary trick: to restore the tab showing up in the ribbon, you do not need to un-install anything: just reassociate .ISO with Explorer (right-click on any .ISO, Open with... submenu, select File Explorer and check the Always use... box; you can do the same thing with the Associate control panel). So +1 for @Solitz which aimed pretty well in the dark!
    – AntoineL
    Sep 23, 2015 at 9:29
  • 3
    +1 for sorting out the file association issue. I hate to think how many people have purchased disc burning software due to this.
    – david25272
    Oct 28, 2015 at 22:57
42

For others, who don't have the "Manage" tab in Explorer, use "Open With" -> "Other application" -> select "c:\windows\system32\isoburn.exe"

5
  • This suggestion did not work in my system. Probably, some privilege problem or something else. Dec 25, 2015 at 11:47
  • 3
    Wow, thanks a lot, man. I can't believe how MS hides this feature. Why on earth is it not accessible via the right-mouse click menu? Jun 4, 2016 at 17:00
  • This saved my bacon, I wasn't getting the manage option. Thanks a ton!!!
    – Justin
    Aug 18, 2017 at 23:43
  • 1
    This didn't work but I was able to run it from cmd prompt instead and pass in the name of the file Jan 17, 2018 at 0:07
  • This worked for me on Win 10 Home upgraded from Win 7, where the accepted answer did not. Cheers!
    – beercohol
    Oct 6, 2018 at 17:21
-3

I'm not sitting at a W10 machine, but the way I did it in W8.1 was:

Right-click -> Open with -> Windows Explorer

Then I selected all the files (CTRL+A)

Share ribbon -> Burn to disc
4
  • That option didn't show up under share.
    – user403574
    Aug 11, 2015 at 6:29
  • What about Send To -> Disk drive? Aug 11, 2015 at 6:35
  • Nope, stopped at Desktop. It was the VCD association that wasn't allowing anything to show up. I removed it, and everything works now.
    – user403574
    Aug 11, 2015 at 6:37
  • 5
    -1 ... What about bootable iso files?
    – kv1dr
    Oct 24, 2015 at 17:05

You must log in to answer this question.