43

I recently started experiencing an issue with my PC, which runs Windows 10 Pro. It wakes from hibernation at seemingly random times. I have done the following to try and troubleshoot the issue:

  • Turn off wake timers
  • Disable all peripherals from waking the system
  • Unplug network cable (No Wi-Fi)
  • Try another power outlet

The computer still wakes at random times. When issuing the command

powercfg /lastwake

I get the following:

Wake History Count - 1
Wake History [0]
    Wake Source Count - 0

I absolutely need Wake on LAN to work on the system, and it always has before. This issue only started recently.

21

I found that it was the "Allow Wake Timers" detailed here.

This has worked for me so far. Go to:

Control Panel\Hardware and Sound\Power Options\Edit Plan Settings

Click "Change advanced power settings"

Go to "Sleep->Allow wake timers" and change the setting to Disable.

And also from here.

Go to Task Scheduler

Find NT TASK\Microsoft\Windows\UpdateOrchestrator\Reboot

Its actually just named Reboot but you have to go inside those folders

Right Click > Properties > Conditions

Uncheck Wake the computer to run this task

  • 2
    Didn't work for me :( – Jimmy Dec 31 '15 at 15:17
  • 1
    Disabling wake timers didn't solve the problem for me. It turned out Teamviewer was ignoring the setting (how does a program overrule an OS setting again?) and rebooting anyway. It seems to be solved in the later versions. – cascer1 Mar 13 '16 at 8:58
  • 1
    In addition to this, I had the mouse and the keyboard set as allowed to wake the PC. both of bad quality which kept always on regardless of the PC power status. Disabling both features gave me the working solution in my case – Moslem Ben Dhaou Jul 27 '16 at 10:01
  • Also makes sense to remove NTFS write permissions from this task for all accounts (including SYSTEM). This way updates will not re-enable the wake condition again. The file is located here: C:\Windows\System32\Tasks\Microsoft\Windows\UpdateOrchestrator – Monsignor Dec 10 '16 at 19:10
  • 1
    @jcollum Use psexec to start cmd as SYSTEM (the user with SID S-1-5-18), then open the task scheduler from that cmd (using taskschd.msc command), then perform the changes in that one. Note that psexec needs to run as administrator, so it can do its magic. – Paul Stelian Jul 12 '18 at 0:21
10

The issue was caused by TeamViewer, it creates wake timers that are somehow ran(?) even though wake timers are disabled. Even shutting down TeamViewer doesn't solve the issue for me. But uninstalling TeamViewer resolved the issue.

  • How did you determine this is what caused it to wake? – Dallas Aug 25 '15 at 23:55
  • @smerny - I found it here, Look for an answer by GBoDH containing TeamViewer (the only answer containing TeamViewer on that page) – cascer1 Aug 26 '15 at 19:39
  • I don't have teamviewer installed, and can't find Realtek (or any other) PCIE controller on my machine. Yet the darn computer keeps restarting. – Jimmy Dec 31 '15 at 15:19
1

Another approach is to see which devices are able to wake up the computer :

powercfg -devicequery wake_armed

And then, try to deactivate this device related privilege in devmgmt.msc

0

I think that is not possible to solve it. When some Windows updates are pending due a computer restart and the computer is in hibernate mode, it automatically turns on at the scheduled time to restart. You must restart Windows manually, but if another update requires restart and you don't restart imediatelly, when you put the computer to hibernate, at the next time scheduled to restart , the computer will turn on again. Nevertheless, it is possible to change the schedule time to a period when the computer is normally turned on.

  • How do you change the scheduled time? – Nilzor Sep 22 '15 at 6:16
  • "I don't think a fix is possible" isn't really an answer, unless you really support why it isn't possible. Because there are many reasons this could be happening -- not just Windows updates -- proving that a fix isn't possible would be difficult and tedious. – jvriesem Oct 26 '17 at 17:51
0

FOUND THE PROBLEM:

edit the registry Key hkey_local_machine\software\Microsoft\Windows NT\CurrentVersion\WinLogon and modify PowerdownAfterShutdown and change it to 1

Source: Windows 10 wakes randomly from hibernate - Microsoft Community https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_perf/windows-10-wakes-randomly-from-hibernate/247e69c3-cc7a-40db-b34e-43d8d60e6947?auth=1

Summary: this setting prevents the computer from fully powering down upon "hibernation" if it's set to 0. Response: Who knew there would be any question? But apparently it's one more straw in the nest. If it doesn't work - I'll be back. Upvote please.

My Original post (background facts and personal peeves and observations):

Also have situation - with no teamviewer. The O.S. settings are being ignored, and no WAKE shows up in powercfg -lastwake. At first I thought that there was some intent to wake it - we all did. That is not true - it is just failing to power down. Note that this error is a prime security issue. And, it is standard operating procedure for Microsoft with its impossibly arbitrary levels of complexity, to create the situation incidentally (not accidentally.) They weren't happy with just being impossibly stupid since the browser wars - they had to double down again and again. Someone needs to go in that place and seriously reformat their drive.

  • PARTIAL ANSWER RETRACTION. WORKAROUND. Due to the severe nature of this security issue, if your system persists in waking, after you have done the above steps, use this procedure: enter hibernation, and on shut down PULL THE PLUG and THE BATTERY (for laptops.) IMPORTANT STARTUP ISSUE: reinstall battery / plug in the machine. IT MAY IMMEDIATELY RESTART - wait for it. Do not touch anything except to turn on your monitor. IF NOT, then press the power button / resume key. IT SHOULD RESUME NORMALLY, EITHER WAY. – Ion-Christopher Sep 30 '17 at 10:19
  • 1
    CAUTION: Users who are not familiar with editing the Windows Registry should proceed with caution, as making changes to it can have big consequences for your system. – jvriesem Oct 26 '17 at 17:53

protected by Community Sep 2 '18 at 1:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.