12

I cancelled the Microsoft Windows 10 Reservation and uninstalled KB3035583, but Windows 10 is still trying to install.

After I uninstalled KB3035583 and restarted my laptop as instructed, I could not find KB3035583 to hide it.

Now Windows 10 is sitting in my Windows Update saying that it will install when I restart my computer.

  • TLDR version: set HKEY_LOCAL_MACHINE\SOFTWARE\Policies\ Microsoft\Windows\WindowsUpdate\DisableOSUpgrade to a DWORD of 1. There are various scripts and tools to do this for the neophyte. One called GWX control panel is linked from this article. In that one you need to click on "Disable Operating System Upgrades in Windows Update" to set that bit. – Fizz Dec 11 '15 at 10:20
  • I dont see this as a dupe of that question, this question already had installed those updates and it is about to upgrade, they are asking how to prevent upgrade once it has gotten to this point (downloaded the files and scheduled a restart to install W10), not how to prevent it from starting this whole process in the first place. The other question does not address this situation and none of the answers do either. – Moab May 1 '16 at 16:07
6

Short Version:

Use Windows' Disk Clean-up Tool to remove the installer files so that the upgrade fails (intentionally).

Long Version:

  1. Uninstall KB3035583 and select the option to reboot later.

  2. Run the Disk Clean up tool and select the Clean up system files after the initial scan. Select the Temporary installation files for deletion. Once they are removed reboot your system and then check for Windows Updates once again

  3. Wait for the scheduled time to arrive because that has already been set in motion if you choose a time for the upgrade. One hour prior to that you will see a window on your screen indicating that it is almost time for the upgrade to happen. This dialog does offer you the chance to reschedule as well.

  4. Once the timer reaches zero then the system will begin the upgrade process.

  5. Following the reboot, the attempt to upgrade will fail because you removed the temporary installation files earlier in this scenario.

  6. You now need to check Windows Update and hide KB3035583 and the Windows 10 Upgrade when it is offered so they will not start again.

Source for Long Version

  • Wow. Really useful I'm sure. – Xavierjazz Aug 11 '15 at 16:36
  • Yes very good answer but I had already uninstalled KB3035583 without knowing about the reboot option. Now I can see KB3035583 but do not have the option to uninstall or hide. Win Update says now that it will install Win 10 when I next restart my computer. BUT should I go ahead and run the Disk Cleanup Tool anyway?? Thanks – Majiti1 Aug 11 '15 at 18:10
  • Yes, if you've already removed the KB just run the disk cleanup so that the Win10 install will intentionally fail after you reboot. – Ƭᴇcʜιᴇ007 Aug 11 '15 at 18:13
  • OK I've done it but can't afford to restart until this evening due to ongoing projects. Will update this thread when I know whether this has succeeded. – Majiti1 Aug 11 '15 at 19:30
  • Or let install start and select disagree on terms of use. I wonder if it will start all over after reboot though. – Moab Aug 11 '15 at 22:16
5

(The solution to your problem is the reg hack listed further below, but I've included the broader description of this whole issue, anyway.)

KB3035583 showed up on AGAIN on a plethora of my client's systems a few days (10/10/15) ago after I had already removed it, unchecked it and hid it weeks earlier. The reason is that Microsoft keeps re-releasing these updates as if they are new.

Furthermore, it appears that the update option, "check for updates but let me choose whether to download and install them", has somehow been ignored with one of these re-released updates as I've found systems magically reset to "Install Updates Automatically", even on systems where the users don't even know how to access an administrator account.

On 10/10/2015 ago I found KB3035583 installed AGAIN on several systems I support and had to uninstall it AGAIN. I then had Update find it again, unchecked it and hid it, and lo and behold, the Windows 10 installer itself was STILL pending as the only available update!

Looking at "view other updates", I found the Windows 10 installer itself included, and then unchecked and hid it, and that actually BROKE Microsoft updates! After I did the above, update would immediately fail with an error (I think 0x80240019: "WU_E_EXCLUSIVE_INSTALL_CONFLICT An exclusive update cannot be installed with other updates at the same time").

This happened on ALL the systems at one business I support!

Fortunately I had encountered this problem before when I had had to roll back to Windows 8.1 from Windows 10 for a client who was tricked into installing Windows 10, so I knew what to do, namely apply the following .reg hack (it will solve the above problems on both Windows 10 and Windows 8):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\OSUpgrade]
"AllowOSUpgrade"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\OSUpgrade\State]
"OSUpgradeState"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"DisableOSUpgrade"=dword:00000001

[Note: copy the above in a file with .reg type, and execute the reg file by right-clicking and selecting "Merge".]

This reg hack can be applied at any time when removing, unchecking and hiding KB3035583 and the Windows 10 installer update itself, but the simplest way to use the reg hack is to first uninstall KB3035583, and then apply the above reg hack BEFORE rebooting, namely first use:

wusa /uninstall /kb:3035583 /norestart /quiet
wusa /uninstall /kb:2952664 /norestart /quiet

then apply the .reg reghack, and then reboot. I've found that if the reg hack is applied that way, the Windows 10 update installer itself will not come back, though you still have to recheck for updates after the boot, to find KB3035583 AGAIN and then uncheck and hide it.

Note KB2952664 comes back too, and if you want to make sure you've removed ALL the telemetry put the following in a .bat file:

@echo on
wusa /uninstall /kb:3035583 /norestart /quiet
wusa /uninstall /kb:3022345 /norestart /quiet
wusa /uninstall /kb:3068708 /norestart /quiet
wusa /uninstall /kb:3075249 /norestart /quiet
wusa /uninstall /kb:3080149 /norestart /quiet
wusa /uninstall /kb:2990214 /norestart /quiet
wusa /uninstall /kb:3012973 /norestart /quiet
wusa /uninstall /kb:2952664 /norestart /quiet
wusa /uninstall /kb:2976978 /norestart /quiet
pause

and run the above batch file, THEN do the .reg hack, and then reboot, and as I said before, you will then have to have update check for new updates, find KB3035583 and KB2952664 and uncheck and hide them.

At this point in the game, because of what Microsoft is doing to my clients with their outrageous, repeated attempts to force Windows 10 onto my client's computers and thereby completely wreck their businesses if they succeed, my only choice is to turn automatic updates off altogether with "Never check for updates" and manually check once or twice a year and see if there's anything worth allowing to install.

  • In my experience what the top-voted post suggests is not enough, i.e. even with KB3035583 (GWX) removed it will still try to install the upgrade unless DisableOSUpgrade is turned on. There's a nice utility to do this (and mess with GWX) found viat this article, called GWX control panel. The DisableOSUpgrade bit is in the "Are Windows Updates OS upgrades enabled?" button. – Fizz Dec 11 '15 at 10:08
  • Also uninstalling the telemetry updates is not necessary for this fix to work, i.e. getting rid of GWX and that DisableOSUpgrade are enough... although there may be other reasons to get rid of the telemetry updates. – Fizz Dec 11 '15 at 11:12
  • I wrapped this and the reg change suggested by @Alex G. into a batch file at gist.github.com/maphew/ce01f28851dd15c8948a – matt wilkie Dec 23 '15 at 19:57
2

Make sure you did not reserve Windows 10. If you did, cancel the reservation.

Then create this DWORD registry entry using regedit with admin rights and set it's value to 1.

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Gwx]
"DisableGwx"=dword:00000001

You might have to create the "GWX" registry key before you can create the DWORD inside of it.

Reboot. You'll never hear about it again.

0

The short answer: 1. Restart. 2. While system is starting again, before completing its task, press "kill" button (on/off for 3 secs.) 3. Start system - update is automatically removed.

I have had this problem twice. The first time about 6 months ago win10 was starting to load and I panicked and "killed" it. This time, I had forgotten I wanted to go into "safe" mode and didn't want to wait for the system to initialise, so I did the same. Not very elegant, but both times it worked.

I am not very computer savvy, but possibly this action corrupts the update??

-1

This is now easy with Never 10, a portable utility to prevent Windows 10 upgrades.

  • might be worth fleshing out your answer (s) with how this works, and how to use it. – Journeyman Geek Mar 31 '16 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.