13

I have no Wireless adapter showing under Control Panel → Network and Internet → Network Connections. I just see Bluetooth and Ethernet.

How do I reinstate the Wireless adapter in Windows so I can make a connection to a wireless network?

I am also missing the option to "manually connect to a wireless network", as shown here:

set up a connection or network

It is a desktop Windows 10 machine with a Linksys AC1200 USB wireless adapter plugged in and I am trying to connect to a 4G hub.

Linksys AC1200 is present and enabled in Device Manager (reporting as Linksys WUSB6300). The drivers are the latest from the Linksys website.

  • How did you solve it? I have exactly the same symptoms and I know that it is not driver nor hardware at fault, its plainly stupid Windows 10 issue. I added USB network adapter -- they both appear in hardware manager but neither in Network Connections, moreover everything works fine in Linux. – MariusM May 11 '16 at 20:41
12

I had similar situation where the network drivers and the hardware were fine (Device Manager listed all network adapters and Linux used the network just fine, but there was no network in Windows 10 and no Network Connections in network settings). My guess is that I had Cisco AnyConnect VPN installed in Windows 8.1 and then upgraded to Windows 10 where it all got messed up. Many users experienced that and there were many suggestions and none of them worked.

Eventually I had to run the following command to reset the absent network connections:

netcfg -d

The first time it failed and gave many errors. Then I tried netcfg -d command again and then it was successful (bizarrely). Then I rebooted and suddenly Windows 10 started picking up networks.

Now it can associate with WiFi AP securely but it still fails to get an IP address... well, at least something.

| improve this answer | |
  • 1
    After 6 agonizing hours(fear of clean re-install) of trying all options ipconfig, netsh winsock reset e.t.c. What worked for me was running netcfg -d thrice. i ran it once restarted with no luck. So i ran it once had threw erros, ran it the second time got one error, ran it the third time got no error. Restarted and my wifi icon was again visible, internet connection all worked. Really weird – Ahmed Alejo Jan 29 '17 at 23:42
2

This is a known issue with Win 10 if you have older VPN software installed like Cisco or in my case Junos. What worked for me was to uninstall the VPN and reboot. However the articles out there suggest registry editing:

Windows 10 looses wifi after upgrade

Start CMD as an admin

reg delete HKCR\CLSID{988248f3-a1ad-49bf-9170-676cbbc36ba3} /va /f

next in the same CMD:

netcfg -v -u dni_dne

reboot and wifi should be back.

However I got the "registry key not found so I unstalled the VPN, reboot and wifi is back. Next I installed a new version from Win 10 store and everything works great!

| improve this answer | |
  • I did have ShrewSoft installed. The particular GUID didn't work for me, but I reckon that's going to be the reason why. Tried ripping everything with "shrew" in it out of the registry, but no joy yet. – Sean Kearon Aug 11 '15 at 20:35
  • 1
    i got to netcfg -d from your answer, ran it once but found out multiple run seems to fix the issue tipped by @MariusM – Ahmed Alejo Jan 29 '17 at 23:49
1

Go into Device Manager and see if the driver is installed under the Network Adapters category. In device manager you can also check if the driver is disabled or not. You can open Device manager by following these steps, or you can search for devmgmt.msc in the search bar from the Start Menu.

If the driver is not installed, go to the manufactures website and download it.

| improve this answer | |
  • Yes, that's all good. I've updated the description to show that. – Sean Kearon Aug 11 '15 at 19:32
  • @SeanKearon Did this happen right after the upgrade? When I upgraded, I also had problems with a few drivers. They did appear in device manager, but failed to work. I simply uninstalled and reinstalled them and they worked like a charm. Either way I'd try to uninstall and reinstall the driver. – DrZoo Aug 11 '15 at 19:35
  • Thanks - have tried that. No avail. Think it's related to TomEus' answer. – Sean Kearon Aug 11 '15 at 20:34
1

I just had the same issue. Drove me nuts. No connection options listed except Broadband and dial-up (what year is this??), with an Ethernet connection. I saw that a Windows Update had been installed this morning, about the time that the wifi crapped out. Did a system restore back to the update installation and voila---my wifi adapter was back. I knew it was something with the laptop because my tablets and phone wifi were both fine.

| improve this answer | |
0
  1. Open Device Manager, open the drop-down Network adpaters
  2. Right-click Network adapters
  3. Select Scan for hardware changes
  4. If you can't see your Wireless adapter, go to step 11
  5. If you can see it, right-click on the adapter
  6. Select Uninstall ( this should only uninstall you driver software, not delete it)
  7. Now right-click Network adapters again
  8. Select Scan for hardware changes. This should re-detect your wireless adapter)
  9. Once detected, restart you machine
  10. Make sure your Wireless adapter in Network And Sharing Center is Enabled. Now try what you have to.
  11. If you cant find you your Wireless adapter device, you may need to properly install a wireless adapter driver. You'll have to do it perfectly, or have a service person do it for your machine

PS: If you want to create a wifi hotspot (when your wireless adapter is working properly), try the following command in Command Prompt

netsh wlan connect ssid=YOURSSID name=PROFILENAME

Replace YOURSSID with your ssid, and PROFILENAME with a name for you connection

| improve this answer | |
0

I have had same issues but got it resolved. Always turn off the wifi of PC/Laptop before shutdown. Whenever PC/Laptop is again started wifi adaptor will be available under network adaptor tab. Switch on Wifi and search for required wifi network. Hope this works for all.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.