15

I used WinKey + S very much on Windows 8.1. Now when I installed Windows 10 it seems to be a problem with the search indexer. It can't find anything but some 'settings' items.

Things i've tried:

  • Rebuilding the indexer
  • Running the troubleshooter
  • Checking the 'allow files to be indexed' on my both partitions
  • Restarting the Windows Indexer Service
  • Deleting the 'C:\ProgramData\Microsoft\Search' folder

Notes:

  • Cortana is not available on my region
1

Check how many items are in your search index: Right-click start button -> Control Panel -> Indexing Options -> Modify

I found that having a large number (in the hundreds of thousands to millions) of items caused search to run slowly and sometimes fail.

See if my more detailed answer here helps you out: https://superuser.com/a/961511/171407

1

What fixed this issue for me was making sure the folders that were included to be indexed (as shown by Indexing Options dialog) had been given basic read, execute, and list folder contents permissions for the SYSTEM user, as shown below. I guess Windows can't index a folder it doesn't have permission to access.

Folder Properties > Security

Hat tip: https://www.tenforums.com/general-support/26645-file-explorer-search-not-working.html

protected by Community Dec 17 '15 at 5:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.