4

So I've just upgraded to Windows 10 from Windows 7. So far I'm not impressed. I could talk about other problems I've been having, however there's one main issue that has been bothering me.

When I restart the computer, my Wi-Fi connection is limited. However, if I disconnect from it, and reconnect again, it works fine.

This is quite annoying, as I don't want to have to disconnect and reconnect my Wi-Fi every time I restart my computer. I've tried lots of solutions that people have given when they have limited connection, but on reboot it still shows up as limited, and will only go properly when I disconnect and reconnect to it.

Any advice?

11
  • 2
    Have you tried installing the latest drivers for Wireless adapter ?
    – clhy
    Aug 11, 2015 at 20:36
  • @The_IT_Guy_You_Don't_Like Thanks for the reply, according to device manager my adapter is up to date.
    – Jeff
    Aug 11, 2015 at 20:37
  • 2
    @Jeff Device Manager is not always correct. Check with your device manufacturer for updates.
    – Joseph
    Aug 11, 2015 at 20:56
  • 3
    @Jeff, what device do you have ? Which version of driver do you have installed ? Is it something that you carried over from windows 7 ? Probably not compatible with Windows 10
    – clhy
    Aug 11, 2015 at 21:22
  • @The_IT_Guy_You_Don't_Like I havean asus usb adapter. I'll check the site for drivers, i'll let you know how it goes.
    – Jeff
    Aug 11, 2015 at 23:37

2 Answers 2

0

In most of the cases know it is Bitdefender Firewall blocking connection. To set the Bitdefender Firewall correctly, by following these steps: 1. Open the Bitdefender program 2. Click on the Protection module and then click on the Firewall feature 3. Make sure the Firewall is turned ON and then go to the Adapters tab and perform the following changes:

•at "Network Type" select "Home/Office" •at "Stealth Mode" select "Off" •at "Generic" select "On"

Now close the Bitdefender window and restart your system.

The same can be with other antiviruses having firewalls integrated.

For several devices like Intel 7260/7265 you need to uninstall basic driver and install the one from Intel site.

For Intel 6205 there is a known solution http://www.sysprobs.com/fixed-windows-10-limited-connectivity-not-getting-ip-from-dhcp

Another trick with Wi-Fi adapter is: go to: Control Panel > Device Manager > Network Adapters > right click on the troublesome wireless adapter and select properties. Go to the "Advanced" tab and on the "802.11n Bandwidth" option, select "20MHz/40MHz Auto" and on the "Roaming Aggressiveness" option, select "5. Highest".

0

Did this issue only occurs after restarting?

First of all, please update your wireless network adapter driver to the last version,reinstall compatible wireless adapter driver form manufacturer website. If Wi-Fi is limited after restarting, here are some general solutions we could try at least. Please check for Windows update in control panel, install all available updates turn off Power Saving Mode of Wireless Adapter Settings in the Power Options dialog box.

enter image description here

And, uncheck option “Allow the computer to turn off this device to save power” in Device Manager. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .