Like many others, I'm experiencing network issues after the Windows 10 update, although, the issue I'm experiencing is a little odd.

Every 1.5-2.5 hours the following events happen, in this specific order:

  1. My WiFi connection goes to "limited".
  2. I'm disconnected from my WiFi network, and it shows that "networks are available.".
  3. It shows that "no networks" are available.

My workaround for this is as follows, again in this specific order:

  1. Run the network troubleshooter so it can "find problems".
  2. The network troubleshooter then disables and re-enables my Wireless Network Adapter Driver, and my laptop BSoD'es with the error message SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (Qcamain10x64.sys).
  3. My laptop restarts, I have a connection, and the process starts over again.

I've also observed that I only need a BSoD with the error message SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (Qcamain10x64.sys), and a restart in order to get a connection again.

I know for a fact that this is an issue related to my laptop, because all other devices connected to the network remain unaffected. I'm not sure what might be causing this, but here's some relevant info:

  • My Wireless Network Adapter Driver is a Qualcomm LAN Killer E2201 Driver.
  • My laptop is an Alienware 13.
  • I'm running Windows 10 Home Edition.
  • I've already updated my Wireless Network Adapter Driver to a Windows-10 compatible version.

Can anyone tell me what's causing this, and how I can fix it?

  • 3
    Had to laugh. "Every frequent period, I have to BSoD to get my computer to work again,", you say calmly as if you're not enraged at all... – rlb.usa Aug 11 '15 at 23:44
  • 1
    @rlb.usa Oh, this event has left me far from calm. ;-) – Ethan Bierlein Aug 11 '15 at 23:51
  • 3
    Qcamain10x64.sys = Qualcomm network driver. look for a driver update – magicandre1981 Aug 12 '15 at 4:21

Does it still BSOD if you go to Control Panel\Network and Internet\Network Connections and disable/re-enable the network connection through that?

As for the issue sounds like a driver problem, have you tried using a driver for a slightly newer model from that product line? Sometimes that has worked for me.

| improve this answer | |
  • I have the newest driver available from the product line. I also cannot re-enable it through the control panel either. – Ethan Bierlein Aug 12 '15 at 2:41
  1. Uninstall WiFi drivers

  2. Download these Drivers packages for Killer products that include base drivers only (no Killer Features).

  3. Install.

  4. Done. Works like a champ. No discos.

| improve this answer | |

Before changing / uninstalling any driver, it is desirable to note the driver provider, date and version so that starting point is known. I have had to rollback drivers for devices and used this type of configuration management information to ID drivers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.