2

This question already has an answer here:

So I have just recently installed Windows 10 and I'm needing to get into my BIOS (legacy, not UEFI BIOS). I have turned off Fast Startup and Hybernation and I have tried the Advanced Startup. The only problem with Advanced Startup is that it only gives the option for UEFI access, not BIOS. I've also tried removing the hard drive with the OS to just boot to it; that didn't work. I also tried putting in the install disk (USB) to see if I could get to it. That didn't work either. Thanks for any help.

Specs: Windows 10 Enterprise (10240) 64Bit Processor: Intel Core i7-3770 RAM: 12GB Motherboard: Pegatron Corp. 2AD5 (v.1.03)

marked as duplicate by BenjiWiebe, bwDraco, BlueBerry - Vignesh4303, Scott, Raystafarian Aug 20 '15 at 18:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you looked for a bios update for that motherboard? – Moab Aug 11 '15 at 23:15
  • I could not find one. I have an HP ENVY h8-1520t – MrGrigri Aug 11 '15 at 23:47
  • I find it very hard to believe there would be motherboards for third-generation i7 processors with legacy BIOS. What are you actually trying to accomplish? – Daniel B Aug 12 '15 at 18:50
  • @MrGrigri, there is one dated January 2015 on this page – Moab Aug 13 '15 at 18:34
1

A couple of tricks to try:

  1. Press and hold the F key that normally would get you into BIOS on that machine BEFORE you turn the device on.
  2. As soon as you press Power, scrape your finger across all of the F keys back and forth. These two methods have been successful in the past.
  3. If neither of these methods function, you should try flashing your BIOS with the latest version.

Good luck! I'm very interested to find out your results. It may not be an update from the current BIOS you have, but if you install the update available from HP Support: "HP Consumer Desktop PC BIOS Update (ROM Family SSID 2AD5)", it might set things back to default, which is likely what you need at this point.

1

Okay Gents...this is the whole story and solution. Like I've stated in my comment to the original post, I have an HP ENVY h8-1520t.

Problem: I wanted two things that could only be changed in BIOS. The first was to enable Virtualization for laravel production with vagrant. The second was to have BIOS turn on my machine on Monday morning so that it was ready to go when I got into work. The first step had my priority while the second is more of a convenience thing. Before I installed Windows 10, I was on Windows 8.1 and I could very easily access BIOS by pressing F9 or ESC to access the startup menu. However, as soon as I performed a clean install of Windows 10, I could no longer access BIOS. The POST screen would flash so quickly that it is nearly impossible for a human to press the F-key at the right moment. I tried turning off Hibernation and Fast Boot in hopes that I could have enough time to access BIOS. It did not work. Also since I have legacy BIOS and not UEFI, I was not able to access BIOS with the restore settings found here.

Solution: Last night before I went home from work I tried installing HP's Driver installer found here. The installation process went smooth and there were no errors. As soon as I restarted my computer, My computer just kept beeping at me and wouldn't power on. So in my frustration I left for the day. When I came in this morning I counted the beeps and there were 6, HP told me that the issue is with the 3rd party graphics card. So I removed the card I received no beeps, and alas, I was able to access my BIOS. However, I was no longer able to boot to any disk. BIOS could see my drives but it wouldn't give me the option to boot to disk, only network. Come to find out, HP in their infinite wisdom, decide to only trust certain hardware, including hard drives. Since my hard drive and graphics cards are after market, it didn't like them. So I had to disable secure boot. After I disabled secure boot, and enabled a 5 second POST screen delay, as well as enabling Virtualization everything was back to normal. I could plug in my video card and BAM...everything worked well.

I hope this helps those in need. I was pulling my hair out and didn't get much sleep last night thinking that I had killed my motherboard by flashing the BIOS. Thanks Moab and Jamal for you answers.

  • 1
    One advice: if you wish that your answer could help others better, please also rename your question from Windows 10 BIOS to something what users googling the same problem will easily catch. Having crappy title significanly decreases chance of question to be found. – miroxlav Aug 12 '15 at 19:56
  • Are you absolutely sure it’s not UEFI? Just because it’s an ugly text-mode menu doesn’t mean it isn’t UEFI! You can always have Windows installed in BIOS mode, even on UEFI systems. That also makes the “restart to UEFI” setting unavailable, of course. – Daniel B Aug 12 '15 at 20:53
  • Because under my System Information it states BIOS Mode as Legacy and not UEFI. – MrGrigri Aug 12 '15 at 20:59
  • That only means Windows is installed in BIOS mode. – Daniel B Aug 12 '15 at 21:07
  • Then is there a way that I could flip a setting to use UEFI instead? If not, then I'm not sure if this route could have helped my situation. But if so, it would be great to know! – MrGrigri Aug 12 '15 at 21:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.